UVA - 10382 (区间覆盖贪心)

Description

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler
is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the
distance from the left end of the center line and its radius of operation.
What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

在这里插入图片描述

Input

Input consists of a number of cases. The first line for each case contains integer numbers n, l and w
with n ≤ 10000. The next n lines contain two integers giving the position of a sprinkler and its radius
of operation. (The picture above illustrates the first case from the sample input.)

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass.
If it is impossible to water the entire strip output ‘-1’.

Sample input

8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1

Sample output

6
2
-1

分析

洒水器覆盖形状为圆形,而草坪为长方形,所以将洒水器的覆盖形状转化为长方形。
要想覆盖完,且洒水器最少,按区间的左端点从小到大排序,依次处理每个区间,选择能够覆盖点t,且右端点最大的,更新覆盖点为此右端点,直至,找完端点,或找不到跳出。
最后根据能够覆盖的最大右范围判断输出。

代码

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
    double l,r;
}st[10010];
bool cmp(node x,node y)
{
    return x.l<y.l;
}

int main()
{
    int n,l,w;
    while(~scanf("%d%d%d",&n,&l,&w))
    {
        int i,j,g=0,s=0;
        double t1,t2,t3;
        for(i=0; i<n; i++)
        {
            scanf("%lf%lf",&t1,&t2);
            if(t2*2<=w) continue;
            t3=sqrt(t2*t2-(w/2.0)*(w/2.0));
            st[g].l=t1-t3;
            st[g++].r=t1+t3;
        }
        sort(st,st+g,cmp);
        double ma=0,t;
        for(i=0; i<g&&ma<l; i++)
        {
            t=ma;
            int fg=0;
            for(j=i; j<g&&st[j].l<=t; j++)
            {
                if(ma<st[j].r)
                    ma=st[j].r,i=j,fg=1;
            }
            if(fg) s++;
            else break;
        }
        if(ma>=l) printf("%d\n",s);
        else printf("%d\n",-1);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值