You can say 11

Your job is, given a positive number N, determine if it is a multiple of eleven.
Input
The input is a file such that each line contains a positive number. A line containing the number ‘0’ is
the end of the input. The given numbers can contain up to 1000 digits.
Output
The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.
Sample Input
112233
30800
2937
323455693
5038297
112234
0
Sample Output
112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.
这是一道判断一个整数能否被11整除的题目,看似简单,然而因为数据太大,导致出错。所以不应该按照平常的思路去接解这道题。

举例(模3举例)
443%3
首先 第一位4%3=a
其次 第二位(a10+4)%3=b;
最后 第三位 (b
10+3)%3=c
如果c为0,则可以整除,否则不可以。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main()
{
    char a[1001];
    while(gets(a))
    {
        if(strcmp(a,"0")==0)
            break;
        int i,ans,len;
        len=strlen(a);
        i=1;
        ans=0;
        for(i=0;i<len;i++)
        {
            ans=(ans*10+a[i]-'0')%11;
        }
        if(ans==0)
            printf("%s is a multiple of 11.\n",a);
        else
            printf("%s is not a multiple of 11.\n",a);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值