Description
二叉树的先序建树和后序输出
Input
输入一行只包含大写字母的字符串,字符串长度小于100,#表示空节点,请按照先序遍历,输出后序遍历
Output
输出后序遍历,注意不要输出空节点,序列末尾不要输出空格
Sample Input
AB#DE###C#F##
Sample Output
EDBFCA
先奉上WA的代码
#include <bits/stdc++.h>
using namespace std;
#define ll long long
char s[110];
char r[110];
int l;
void post(int p)
{
int root = p;
if(p*2<=l&&r[p*2]!='#') post(p*2);
if(p*2+1<=l&&r[p*2+1]!='#') post(p*2+1);
printf("%c", r[root]);
}
int main()
{
scanf("%s", s+1);
l = strlen(s+1);
memset(r,'#',sizeof(r));
int root = 1;
r[root] = s[1];
root *= 2;
for(int i = 2; i < l; i++){
if(s[i]!='#'){
r[root] = s[i];
root *= 2;
}else{
if(root%2==0){
root++;
}else{
while(root%2!=0){
root /= 2;
}
root++;
}
}
//cout << root << " " << r[root] << endl;
}
//printf("%s\n", r+1);
post(1);
return 0;
}
上面这种做法之所以不行,就是如下图这种情况,完全建一颗树就会浪费大量内存(题目的26个字母,按照下图的情况,就需要建一颗26层的二叉树,它的结点个数达到了2^26-1,也就是67108863个,而实际有用的节点只有26个,显然非常浪费内存)。
于是乎根据高人的指点,有了下面这种方法,利用结构体数组记录某根结点的左结点和右节点,从而减少内存使用。
#include <bits/stdc++.h>
using namespace std;
char s[110];
int n;
int pos = 0;
struct p{
int lc;
int rc;
}f[30];
int dfs();
void post(int root);
int main()
{
while(~scanf("%s", s)){
for(int i = 0; i < 26; i++){
f[i].lc = -1;
f[i].rc = -1;
}
n = strlen(s);
dfs();
post(s[0]-'A');
printf("\n");
}
return 0;
}
int dfs()
{
int root = s[pos]-'A';
pos++;
if(s[pos]!='#') f[root].lc = dfs();
pos++;
if(s[pos]!='#') f[root].rc = dfs();
return root;
}
void post(int root)
{
if(f[root].lc!=-1) post(f[root].lc);
if(f[root].rc!=-1) post(f[root].rc);
printf("%c", root+'A');
}