PAT甲级 A1044 Shopping in Mars (25分) (题目 + 代码 + 详细注释)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

//题意是:给出一个数字序列,找到序列中所有和为S的连续子序列若不存在,则找出和大于S且最接近的子序列

//思路:分两步:(1)判断是否存在这样的序列  (2)把满足条件的情况输出

//思想:二分(或two pointers)

//具体实现,详见AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>

using namespace std;
int sum[100005];        //sum[i]表示从第1个到第i个之间所有的数字之和,且易知sum数组是严格递增的

int main() {
	int n, S, nearS = 100000005;      //S是题目给出的和,nearS表示最接近S的和,初始化为最大数据1e+8
	cin >> n >> S;                      //读入值
	for (int i = 1; i <= n; i++) {
		cin >> sum[i];              
		sum[i] += sum[i - 1];           //读入时算出sum[i]的值
	}

//找到nearS
	for (int i = 1; i <= n; i++) {
		int j = upper_bound(sum + i, sum + n + 1, S + sum[i - 1]) - sum;   //调用该库函数,找出第一个j使得i和j之间的数字之和大于S
		if (sum[j - 1] - sum[i - 1] == S) {      //由于找到的j是大于,所以分析j - 1,sum[j-1]-sum[i-1]是第i个到第j - 1之间所有数的和
			nearS = S;             //更新最接近S的值为S,这时就可以跳出循了
			break;
		}
		int k = sum[j] - sum[i - 1];    //如果上一步没跳出循环,则说明[i,j-1]之间的数之和小于S,因此直接分析[i, j],这个结果肯定是大于S的
		if (k < nearS && j <= n)         //判断是否更新nearS,后一个条件是因为如果没找到满足条件的j,那么j的下标是n + 1
			nearS = k;
	}

//输出部分, 和上面的循环差不多,只是将S换成了nearS
	for (int i = 1; i <= n; i++) {
		int j = upper_bound(sum + i, sum + n + 1, nearS + sum[i - 1]) S- sum;    
		if (sum[j - 1] - sum[i - 1] == nearp)
			cout << i << "-" << j - 1 << endl;
	}

	return 0; 
}

//最后声明下,本题代码灵感来自于晴神笔记,如有侵权,请联系删除!

//先看后好习惯哦!!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值