PAT甲级A1044

PAT甲级 A1044

题目详情

1044 Shopping in Mars (25分)
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10
​5
​​ ), the total number of diamonds on the chain, and M (≤10
​8
​​ ), the amount that the customer has to pay. Then the next line contains N positive numbers D
​1
​​ ⋯D
​N
​​ (D
​i
​​ ≤10
​3
​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5

解题思路

一开始我的想法是采用动态规划,DP区间规划,100000*100000,但是会产生内存超限问题,开的数组大小太大。后面想直接采用累加数组,但是存在三个运行超时的测试点。这题我是真的没有想到可以用二分查找,循环N次,即每次搜索以i为开始的可能区间,用二分查找查找此时的最小大于等于M的区间,并执行相关的操作,极大的压缩了时间复杂度和空间复杂度
以下为AC代码

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<memory.h>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
using namespace std;
const int maxn = 100001;
int sum[maxn];
vector<int> chains;
class qj {
public:
	int begin;
	int end;
};
bool cmp(qj a, qj b) {
	return a.begin < b.begin;
}
int main() {
	int N; int M;
	cin >> N >> M;
	for (int i = 0; i < N; i++) {//用了一个sum数组存储当前的所有的数据情况
		int temp; scanf_s("%d",&temp);
		chains.push_back(temp);
		if (i == 0) {
			sum[i] = temp;
		}
		else {
			sum[i] = temp + sum[i - 1];
		}
	}
	vector<qj> pay; int minlost = 1e9;
	for (int i = 0; i < N; i++) {//每次二分均查找比他大的所有可能区间
        int low = i, high = N, mid;
        while (low <= high)//进行二分查找,每次均找到最小的那个值
        {
            mid = (low + high) / 2;
            if (sum[mid] - sum[i - 1] < M)
                low = mid + 1;
            else
                high = mid - 1;
        }
        if (sum[low] - sum[i - 1] >= M)
        {
            if (sum[low] - sum[i - 1] < minlost)
            {
                minlost = sum[low] - sum[i - 1];
                pay.clear();
                qj temp;
                temp.begin = i; temp.end = low;
                pay.push_back(temp);
            }
            else if (sum[low] - sum[i - 1] == minlost)
            {
                qj temp;
                temp.begin = i; temp.end = low;
                pay.push_back(temp);
            }
        }
	}
    for (int i = 0; i < pay.size(); i++) {
        cout << pay[i].begin+1 << "-" << pay[i].end+1 << '\n';
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值