Codeup 1919A 问题A:二叉排序树(附坑点分析)

问题 A: 二叉排序树

时间限制: 1 Sec  内存限制: 32 MB

题目描述

输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。

输入

输入第一行包括一个整数n(1<=n<=100)。接下来的一行包括n个整数。

输出

可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。每种遍历结果输出一行。每行最后一个数据之后有一个空格。

样例输入

1
2 
2
8 15 
4
21 10 5 39 

样例输出

2 
2 
2 
8 15 
8 15 
15 8 
21 10 5 39 
5 10 21 39 
5 10 39 21 

题意很简单,按照给定序列建一颗二叉查找树,要求输出先序、中序和后序的序列。

坑点是:不能有重复的键值,这个我也试了好几次才发现(坑啊),因为有的书上说可以有重复的键值,有的书说没有,但是题目也没有说明(QWQ)

代码:

#include<bits/stdc++.h> 
using namespace std;
typedef long long ll;

struct node {
    int data;
    node* lc, * rc;
};

void insert(node*& root, int data) {      //建树
    if (!root) {
        root = new node;
        root->data = data, root->lc = root->rc = NULL;
        return;
    }
    if (data == root->data)  return;       //关键步骤(少了这一步只能得50分了~)
    if (data < root->data)  insert(root->lc, data);
    else insert(root->rc, data);
}

void preorder(node* root) {         //先序
    if (!root)  return;
    printf("%d ", root->data);
    preorder(root->lc);
    preorder(root->rc);
}

void inorder(node* root) {           //中序
    if (!root)  return;
    inorder(root->lc);
    printf("%d ", root->data);
    inorder(root->rc);
}

void postorder(node* root) {        //后序
    if (!root)  return;
    postorder(root->lc);
    postorder(root->rc);
    printf("%d ", root->data);
}

int main() {
    int n;
    while (scanf("%d", &n) == 1) {
        node* root = NULL;
        for(int i = 0; i < n; i++) {
            int x;
            scanf("%d", &x);
            insert(root, x);
        }
        preorder(root);
        printf("\n");
        inorder(root);
        printf("\n");
        postorder(root);
        printf("\n");
    }

    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值