1010 Radix (25 分) 暴力枚举

1010 Radix (25 分)
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

简单来说,题目的意思是n1,n2,在其中一个数是radix进制下,另一个数是多少进制会相等
虽然表示的数只有0-35,但是题目可没有说进制只能在36以内
比如n1=1001,n2=11,radix=10 --> 那么在1000进制下,n1就会等于n2.

正确的解法:二分进制。
本文不写正解,写暴力。
思路:

从2进制开始枚举,判断n1和n2是否相等;
枚举的过程中,算一下目前程序跑了多少时间
题目约束400ms ,那么跑370ms就退出暴力枚举
最后看有没有枚举到解,有则输出,无则输出无解

clock() 函数返回自程序开始运行的处理器时间,(这里的时间并不是以秒为单位)
两个clock_t 相减后,除以CLOCKS_PER_SEC:表示,处理的时间,单位为秒。

代码:

#include <bits/stdc++.h>
using namespace std;
#define ll long long
__int128 to_k(string s, int k)
{
    __int128 ans = 0, p = 1;
    for (int i = 0; i < s.size(); i++) {
        int x;
        if (s[i] >= '0' && s[i] <= '9')
            x = (s[i] - '0');
        else x = (s[i] - 'a' + 10);
        if (x >= k)return -1;
    }
    for (int i = s.size() - 1; i >= 0; i--)
    {
        if (s[i] >= '0' && s[i] <= '9')
            ans += (s[i] - '0') * p;
        else
            ans += (s[i] - 'a' + 10) * p;
        p *= k;
    }
    return ans;
}
char ss1[100],ss2[100];
int main()
{
    string s1, s2;
    int tag, radix;
    //	cout << to_k("zzzzzzzzzz",36) << endl;
    scanf("%s%s%d%d",ss1,ss2,&tag,&radix);
    s1=ss1,s2=ss2;
    clock_t head = clock();
    if (tag == 2)
        swap(s1, s2);
    __int128 t=to_k(s1, radix);
    for (int i = 2; ; i++)
    {
        if (t == to_k(s2, i))
        {
            cout << i << endl;
            return 0;
        }
        clock_t tail = clock();
        if ((double)(tail - head) / CLOCKS_PER_SEC >= 0.37)break;
        //printf("i=%d  %lf\n",i,(double) (tail - head) / CLOCKS_PER_SEC);
    }
    cout << "Impossible" << endl;
    return 0;
}

在这里插入图片描述
这样大部分的测试点能过

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值