HDU 4722 Good Numbers(数位dp基础题)

HDU 4722 Good Numbers
Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).
Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
Sample Input
2
1 10
1 20
Sample Output
Case #1: 0
Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.

这道题的大致意思就是给你一个区间【l,r】之间,让你去求这个区间内数位和能够被10整除的数的个数。
这道题应该是比较基础的数位dp题吧。
具体看代码(来人放代码):

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
int a[20];
LL dp[20][12];
LL dfs(int pos,int sum,bool lim){
    if(pos<1)
        return sum % 10 == 0;
    if(!lim&&dp[pos][sum]!=-1)
        return dp[pos][sum];
    int up = lim ? a[pos] : 9;
    LL ans=0;
    for (int i = 0; i <= up;i++){
        int sum1 = (sum + i) % 10;//取余
        ans += dfs(pos - 1, sum1, lim && i == up);
    }
    if(!lim)
        dp[pos][sum] = ans;
    return ans;
}
LL solve(LL x){
    int pos = 0;
    while(x){
        a[++pos] = x % 10;
        x /= 10;
    }
    return dfs(pos , 0, true);
}
int main(){
    int t;
    cin >> t;
    LL l, r;
    for (int i = 1; i <= t;i++){
        memset(dp, -1, sizeof dp);
        scanf("%lld%lld", &l, &r);
        if(l==0)cout << "Case #" << i << ": " << solve(r) << endl;
        else 
        printf("Case #%d: %lld\n", i, solve(r) - solve(l - 1));
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值