HDU4722:Good Numbers(数位DP)

Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input
  
  
2 1 10 1 20
 

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
 


题意:求出区间内每位之和能被10整除的数的个数

思路:这题是简单的数位DP,当然用规律也能破

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

__int64 bit[20];
__int64 dp[20][10];
//dp[i][j],长度为i的数与10模为j的个数
__int64 solve(__int64 n)
{
    __int64 ans;
    __int64 tem1 = n,len,sum,i,x,j,k;
    len = sum = ans = 0;
    memset(dp,0,sizeof(dp));
    while(tem1)
    {
        bit[++len] = tem1%10;
        tem1/=10;
    }
    for(i = 1; i<=len/2; i++)//按高位在头排列
    {
        int t;
        t = bit[i];
        bit[i] = bit[len-i+1];
        bit[len-i+1] = t;
    }
    x = 0;
    for(i = 1; i<=len; i++)//从最高位开始
    {
        for(j = 0; j<10; j++)//将高位的全部枚举一次
            for(k = 0; k<10; k++)
                dp[i][(j+k)%10]+=dp[i-1][j];
        for(j = 0; j<bit[i]; j++)//枚举该位的数字到界限
            dp[i][(x+j)%10]++;
        x = (x+bit[i])%10;
    }
    if(!x)
        dp[len][0]++;
    return dp[len][0];
}

int main()
{
    __int64 T,l,r,cas = 1;
    __int64 ans;
    scanf("%I64d",&T);
    while(T--)
    {
        ans = 0;
        scanf("%I64d%I64d",&l,&r);
        ans = solve(r)-solve(l-1);
        printf("Case #%I64d: %I64d\n",cas++,ans);
    }

    return 0;
}

 

而且通过观察我们可以发现,每个数从0到该位数字中,每位和能被10整除的个数是该数字除以10,然后再枚举各位到界限的个数之和

于是可得以下代码

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

__int64 solve(__int64 n)
{
    if(n<0)
        return 0;
    __int64 t = n/100,i,ans = 0,sum;
    ans = t*10;
    for(i = t*100;i<=n;i++)
    {
        sum = 0;
        __int64 tem = i;
        while(tem)
        {
            sum+=tem%10;
            tem/=10;
        }
        if(sum%10 == 0)
        ans++;
    }

    return ans;
}

int main()
{
    __int64 T,l,r,cas = 1,ans;
    scanf("%I64d",&T);
    while(T--)
    {
        scanf("%I64d%I64d",&l,&r);
        ans = solve(r)-solve(l-1);
        printf("Case #%I64d: %I64d\n",cas++,ans);
    }

    return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值