POJ 3090 Visible Lattice Points

Description
A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.在这里插入图片描述
Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, y ≤ N.
Input
The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output
For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input
4
2
4
5
231

Sample Output
1 2 5
2 4 13
3 5 21
4 231 32549

submit

这道题的大致意思就是给你一个平面直角坐标系(第一象限),给你一个数N,在这N * N 的矩阵中每一个整数坐标上插着一枚钉子(除(0,0)这个点),让你在原点处看一共能看到多少个钉子,如果一个钉子能被看到说明,其与原点所连的直线上,其前面没有钉子。
思路:经过观察分析,我们可以很容易的方向一个钉子在(x,y)坐标上,如果能够被看到的话,那么gcd(x,y)=1。同时题目给你N * N,图像上的每一个点,它是关于y=x对称的,那么我们只需要统计上半部分或者下半部分就可以了。
这道题可以用两种方法做
1).gcd打表:代码如下

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=1005;
int sum[maxn];
int num[maxn];
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b); 
} 
void init(){
	memset(sum,0,sizeof sum);
	memset(num,0,sizeof num);
	for(int i=1;i<maxn;i++){
		for(int j=1;j<=i;j++){
			if(gcd(i,j)==1)num[i]++;   
		}
	}
	for(int i=1;i<maxn;i++)sum[i]=sum[i-1]+num[i];
}
int main(){
	int t;
	init();   
	scanf("%d",&t);
	for(int i=1;i<=t;i++){
		int n;
		scanf("%d",&n);
		printf("%d %d %d\n",i,n,sum[n]*2+1);
		//这里加1,是因为我在打表的时候我把y=x算了两次。
		//然后x==0和y==0的时候没算,所以是sum[n]*2+2-1; 
	}
} 

2).欧拉函数(因为我需要gcd(x,y)==1,所以x和y是互质的,可以用欧拉函数求解,在2~N中各个数的欧拉函数,然后将他们加起来,再加3,就是所得答案):

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1005;
int phi[maxn];
int sum[maxn];
void euler(){
	for(int i=1;i<maxn;i++){
		phi[i]=i;
		sum[i]=0;
	}
	for(int i=2;i<maxn;i++){
		if(phi[i]==i)
		   for(int j=i;j<maxn;j+=i)phi[j]=phi[j]*(i-1)/i;
	}
	for(int i=2;i<maxn;i++){
		sum[i]=sum[i-1]+phi[i];
	}
}
int main(){
	int t;
	scanf("%d",&t);
	euler();
	for(int i=1;i<=t;i++){
		int n;
		scanf("%d",&n);
		printf("%d %d %d\n",i,n,sum[n]*2+3);
	}
}

非常感谢苏学长的帮助。

道阻且长
自己选的路 跪着也要走完

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这是一道比较经典的计数问题。题目描述如下: 给定一个 $n \times n$ 的网格图,其中一些格子被标记为障碍。一个连通块是指一些被标记为障碍的格子的集合,满足这些格子在网格图中连通。一个格子是连通的当且仅当它与另一个被标记为障碍的格子在网格图中有公共边。 现在,你需要计算在这个网格图中,有多少个不同的连通块,满足这个连通块的大小(即包含的格子数)恰好为 $k$。 这是一道比较经典的计数问题,一般可以通过计算生成函数的方法来解决。具体来说,我们可以定义一个生成函数 $F(x)$,其中 $[x^k]F(x)$ 表示大小为 $k$ 的连通块的个数。那么,我们可以考虑如何计算这个生成函数。 对于一个大小为 $k$ 的连通块,我们可以考虑它的形状。具体来说,我们可以考虑以该连通块的最左边、最上边的格子为起点,从上到下、从左到右遍历该连通块,把每个格子在该连通块中的相对位置记录下来。由于该连通块的大小为 $k$,因此这些相对位置一定是 $(x,y) \in [0,n-1]^2$ 中的 $k$ 个不同点。 现在,我们需要考虑如何计算这些点对应的连通块是否合法。具体来说,我们可以考虑从左到右、从上到下依次处理这些点,对于每个点 $(x,y)$,我们需要考虑它是否能够与左边的点和上边的点连通。具体来说,如果 $(x-1,y)$ 和 $(x,y)$ 都在该连通块中且它们在网格图中有公共边,那么它们就是连通的;同样,如果 $(x,y-1)$ 和 $(x,y)$ 都在该连通块中且它们在网格图中有公共边,那么它们也是连通的。如果 $(x,y)$ 与左边和上边的点都不连通,那么说明这个点不属于该连通块。 考虑到每个点最多只有两个方向需要检查,因此时间复杂度为 $O(n^2 k)$。不过,我们可以使用类似于矩阵乘法的思想,将这个过程优化到 $O(k^3)$ 的时间复杂度。 具体来说,我们可以设 $f_{i,j,k}$ 表示状态 $(i,j)$ 所代表的点在连通块中,且连通块的大小为 $k$ 的方案数。显然,对于一个合法的 $(i,j,k)$,我们可以考虑 $(i-1,j,k-1)$ 和 $(i,j-1,k-1)$ 这两个状态,然后把点 $(i,j)$ 加入到它们所代表的连通块中。因此,我们可以设计一个 $O(k^3)$ 的 DP 状态转移,计算 $f_{i,j,k}$。 具体来说,我们可以考虑枚举连通块所包含的最右边和最下边的格子的坐标 $(x,y)$,然后计算 $f_{x,y,k}$。对于一个合法的 $(x,y,k)$,我们可以考虑将 $(x,y)$ 所代表的点加入到 $(x-1,y,k-1)$ 和 $(x,y-1,k-1)$ 所代表的连通块中。不过,这里需要注意一个细节:如果 $(x-1,y)$ 和 $(x,y)$ 在网格图中没有相邻边,那么它们不能算作连通的。因此,我们需要特判这个情况。 最终,$f_{n,n,k}$ 就是大小为 $k$ 的连通块的个数,时间复杂度为 $O(n^2 k + k^3)$。 参考代码:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值