08-图8 How Long Does It Take

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i]E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

结尾无空行

Sample Output 1:

18

结尾无空行

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

 

理解分析题意:这是一个AOE网络 

但是这个是以AOE网络的工程项目排序关键路径问题为背景,实际上还是拓扑排序的简单变形

#include<iostream>
#include<vector>
#include<string>
#include<deque>
using namespace std;
class node {
public:
	int V;
	int T;
	node(int v, int t) {
		V = v; T = t;
	}
};
int main() {
	int N, M; cin >> N >> M;
	int m = M;
	vector<vector<node>>Graph(N);
	vector<int>indegree(N,0);
	vector<int>earliest(N,-1);
	deque<int>zero;
	while (m--) {
		int s,e,l;
		cin >> s >> e >> l;
		Graph[s].emplace_back( node(e, l));
		indegree[e]++;
	}
	for (int i = 0; i < N; i++)
		if (indegree[i] == 0) {
			zero.emplace_back(i);
			earliest[i] = 0;
		}
	while (!zero.empty()) {
		int tem = zero.front(); zero.pop_front();
		for (auto n : Graph[tem]) {
			earliest[n.V] = max(earliest[n.V], earliest[tem] + n.T);
			indegree[n.V]--;
			if (indegree[n.V] == 0)zero.emplace_back(n.V);
		}
	}
	int time = 0; int i = 0;
	for (; i < N; i++) {
		if (earliest[i] == -1)break;
		time = max(earliest[i], time);
	}
	if (i == N )cout << time;
	else cout << "Impossible";
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值