PAT刷题之旅 1122-Hamiltonian Cycle-甲级

题目
The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format “Vertex1 Vertex2”, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 … Vn

where n is the number of vertices in the list, and Vi’s are the vertices on a path.

Output Specification:

For each query, print in a line “YES” if the path does form a Hamiltonian cycle, or “NO” if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:

YES
NO
NO
NO
YES
NO
题目大意
给出一个图,判断给定的路径是不是哈密尔顿路径。

分析
1.设置cnt1 判断节点是否多走、少走、或走成环。
2.设置cnt2 判断这条路能不能走通。
3.当cnt1、cnt2都为1时是哈密尔顿路径,否则不是。

#include<iostream>
#include<algorithm>
#include<vector>
#include<set>
using namespace std;
int main()
{
    int n,m,t,x,y,cnt;
    int a[210][210]={0};
    cin>>n>>m;
    for(int i=0;i<m;i++)
    {
        cin>>x>>y;
        a[x][y]=a[y][x]=1;
    }
    cin>>cnt;
    for(int i=0;i<cnt;i++)
    {
        int cnt1=1,cnt2=1;
        cin>>t;
        vector<int>v(t);
        set<int>ss;//注意这条不能写外面,每次都要进行重新查重。
        for(int i=0;i<t;i++)
        {
            cin>>v[i];
            ss.insert(v[i]);
        }
        if(t-1!=n||v[0]!=v[t-1]||ss.size()!=n)//判断cnt1
            cnt1=0;
        for(int i=0;i<t-1;i++)
        {
        	//判断cnt2
            if(a[v[i]][v[i+1]]!=1&&a[v[i+1]][v[i]]!=1)//a[v[i]][v[i+1]]==0
                cnt2=0;
        }
        if(cnt1==1&&cnt2==1)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

参考链接
柳神

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值