A1005 Spell It Right (20分)

A1005 Spell It Right (20分)

一、题目描述

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10100).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

二、题目大意

给出一个非零整数N,求出N中每位数字的和,并用英文单词描述出来。

三、思路

①:该整数N范围是10100以内,所以应该采用字符串的形式进行输入。
②:从第一位开始遍历,直到字符串末尾,计算出每位数字的和sum。
③:对sum的每位数字,从个位开始压栈,最后从栈顶一一输出即可。
④:值得注意的是这里可以使用一个二维字符数组存储0-9的英文单词,最后输出下标为栈顶元素的数组即可。

四、AC代码

#include<bits/stdc++.h>
using namespace std;
char a[][12]={"zero","one","two","three","four","five","six","seven","eight","nine"};
stack<string>ans;
int main()
{
	string str;
	cin >> str;
	long long sum = 0;
	for(int i = 0 ; i < str.size() ; i ++){
		sum += (str[i] - '0');
	}
	int t = 0; 
	do{
		ans. push( a[sum % 10] );
//		t ++ ;
		sum /= 10;
	}while(sum);
	while(!ans.empty()){
		cout << ans.top();
		if(ans.size() != 1) cout << " ";
		ans.pop();
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值