A1001 A+B Format (20分)

A1001 A+B Format (20分)

一、题目描述

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6≤ a,b≤106. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

二、题目大意

计算a和b的合,并用逗号隔开连续的三位数字。

三、思路

1. 思路①

①:计算a+b的总和,若为负数,则先输出‘-’,并把sum取绝对值。
②:把sum的每一位数字一一存入栈中(从个位进栈),每进3位数字再额外压入一个逗号。
③:最后一一输出栈顶即可。

2. 思路②

①:由于数据的范围是给定的,不会超过107。所以我们一一枚举即可

if(sum >= 1000000) printf("%d,%03d,%03d",sum / 1000000,sum % 1000000 / 1000 , sum % 1000);
else if(sum >= 1000) printf("%d,%03d",sum / 1000 , sum % 1000);
else printf("%d",sum);

四、AC代码

1. 代码①

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
stack<char>s;
int main()
{
	ll a,b;
	cin >> a >> b;
	ll sum = a + b;
	if(sum < 0) cout << "-";
	sum = abs(sum);
	int t = 0;
	do{
		t ++;
		s.push(char('0'+(sum % 10)));
		sum /= 10;
		if( t % 3 == 0 && sum != 0) s.push(',');
	}while(sum);

	while(!s.empty()){
		cout << s.top();
		s.pop();
	}
	
	return 0;
}

2. 代码②

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
	ll a,b;
	cin >> a >> b;
	ll sum = a + b;
	if(sum < 0) cout << "-";
	sum = abs(sum);
	if(sum >= 1000000) printf("%lld,%03lld,%03lld",sum / 1000000,sum % 1000000 / 1000 , sum % 1000);
	else if(sum >= 1000) printf("%lld,%03lld",sum / 1000 , sum % 1000);
	else printf("%lld",sum);
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
可以使用面向对象的思想来构建“超市购物”程序。我们可以先定义两个类,一个是商品类,一个是购物者类。商品类中包含属性货物名、货号、价格和数量等信息,还包含获取货物名和价格的方法。购物者类中包含购物清单和购买商品等方法。在购物者类中先定义购物清单列表,再根据购买的商品名称查找商品的价格并计算出总价格。每次购买商品时,还需要统计相应商品的销售数量。 下面是一个示例代码: ```python class Commodity: def __init__(self, name, code, price, quantity): self.name = name self.code = code self.price = price self.quantity = quantity def get_name(self): return self.name def get_price(self): return self.price class Shopper: def __init__(self): self.shopping_list = [] # 初始化购物清单 def add_item(self, commodity, quantity): # 添加购买的商品和对应数量 self.shopping_list.append((commodity, quantity)) def print_receipt(self): # 打印购物清单和总价格 total_price = 0 for commodity, quantity in self.shopping_list: name = commodity.get_name() price = commodity.get_price() sub_total = price * quantity total_price += sub_total print(f"{name} x {quantity} = {sub_total}") print(f"Total price: {total_price}") # 统计销售数量 for commodity, quantity in self.shopping_list: commodity.quantity += quantity # 定义一些商品 commodity1 = Commodity("soap", "A1001", 10, 100) commodity2 = Commodity("pen", "A1002", 5, 200) # 创建购物者并购买商品 shopper = Shopper() shopper.add_item(commodity1, 2) shopper.add_item(commodity2, 3) # 打印购物清单并统计销售数量 shopper.print_receipt() print(commodity1.quantity) print(commodity2.quantity) ``` 运行结果: ``` soap x 2 = 20 pen x 3 = 15 Total price: 35 102 203 ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值