A1012 The Best Rank (25分)

该篇博客详细介绍了如何评估计算机科学专业一年级学生的成绩表现,主要依据C语言、数学和英语三门课程的成绩以及平均分。算法侧重于学生的最佳排名,即在四个排名(C、M、E和平均分)中找到最优。博客提供了输入输出规范,并给出了一段AC代码实现,用于查找指定学生在所有成绩中的最佳排名及对应科目。
摘要由CSDN通过智能技术生成

A1012 The Best Rank (25分)

一、题目描述

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

二、题目大意

给定N个学生的信息和M个要查询的学生信息,输出要查询的学生信息中最前的排名(按照成绩排名),并输出对应的科目。若查询的学生中不在给定的N个学生中,则输出N/A。

三、思路

①:连接体信息,要使用结构体来存储。
②:由于输出4个成绩中最靠前的排名,因此要对四个成绩以高到低的分数进行排序,找出一个学生在四个成绩中排名最前的科目,若排名都一样则按着A>C>M>E的顺序输出。

四、AC代码

#include<bits/stdc++.h>
using namespace std;
struct node{
	int id;
	int score[4];
}t[2050];

int Rank[1000000][4];
int now;
char course[4] = {'A' , 'C' , 'M' , 'E'};
int cmp(node a , node b)
{
	return a.score[now] > b.score[now];
}

int main()
{
	int n , m ;
	scanf("%d%d",&n , &m);
	for(int i = 1 ; i <= n ; i ++){
		scanf("%d%d%d%d" , &t[i].id , &t[i].score[1] , &t[i].score[2] , &t[i].score[3]);
		t[i].score[0] = t[i].score[1] + t[i].score[2] + t[i].score[3];
	} 
	
	for(now = 0 ; now < 4 ; now ++){
		sort(t + 1 , t + n + 1 , cmp);
		Rank[t[1].id][now] = 1;
		for(int i = 2 ; i <= n ; i ++){
			if(t[i].score[now] == t[i - 1].score[now]){
				Rank[t[i].id][now] = Rank[t[i - 1].id][now] ;
			}
			else{
				Rank[t[i].id][now] = i;
			}
		}
	}
	
	for(int i = 1 ; i <= m ; i ++){
		int t;
		scanf("%d",&t);
		if(Rank[t][0] == 0){
			printf("N/A\n");
			continue;
		}
		int k = 0;
		for(int j = 0 ; j < 4 ; j ++){
			if(Rank[t][j] < Rank[t][k]){
				k = j;
			}	
		}
		printf("%d %c\n" , Rank[t][k] , course[k]);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值