A1016 Phone Bills (25分)

A1016 Phone Bills (25分)

一、题目描述

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

二、题目大意

给出一天中24个时间段通话的费用(1分钱/分钟),并给定N条信息,每条信息包括用户的姓名,通话时间,以及通话开始(on-line)和通话结束(off-line)。现需要求每个用户的有效通话(即每个用户都存在on-line和off-line,且on-line和off-line必须相邻)。若存在有效通话,则优先输出姓名字典序最小的用户。

三、思路

①:连接体信息,采用结构体形式进行存储信息。
②:使用bool类型的status存在通话记录,若是on-line则令status为true,若是off-line则令status为false。
③:对用户进行每条信息进行排序。
④:对用户每条信息进行查询,同一个姓名遍历一遍,找出该用户有效通话的次数并输出。
⑤:从通话开始到通话结束,记录时长和对应的费用。

四、AC代码

#include<bits/stdc++.h>
using namespace std;
int d[25];
struct node {
	char name[40];
	int month , dd , hh , mm;
	bool status;
}t[2050];

int cmp(node a , node b)
{
	if(strcmp(a.name , b.name) != 0) return strcmp(a.name , b.name) < 0;
	else if(a.month != b.month) return a.month < b.month;
	else if(a.dd != b.dd) return a.dd < b.dd;
	else if(a.hh != b.hh) return a.hh < b.hh;
	else return a.mm < b.mm;
}

void get_ans(int on ,int off , int &time , int &money)
{
	while(t[on].dd < t[off].dd || t[on].hh < t[off].hh || t[on].mm < t[off].mm){
		time ++;
		money += d[t[on].hh];
		t[on].mm ++;
		if(t[on].mm == 60){
			t[on].mm = 0;
			t[on].hh ++;
		}
		if(t[on].hh == 24){
			t[on].hh = 0;
			t[on].dd ++;
		}
	}
}
int main()
{
	for(int i = 0 ; i < 24 ; i ++){
		scanf("%d" , &d[i]);
	}
	int n ;
	scanf("%d" , &n);
	for(int i = 1 ; i <= n ; i ++){
		char line[10] ;
		scanf("%s" , t[i].name);
		scanf("%d:%d:%d:%d" , &t[i].month , &t[i].dd , &t[i].hh , &t[i].mm);
		scanf("%s" , line);
		if(strcmp(line , "on-line") == 0){
			t[i].status = true;
		}
		else{
			t[i].status = false;
		}
	}
	sort(t + 1 , t + n + 1 , cmp);
	int on = 1 , off ,next;
	while(on <= n){
		next = on;
		int needprint = 0;
		while(next <= n && strcmp(t[on].name , t[next].name) == 0){
			if(needprint == 0 && t[next].status == true) needprint = 1;
			else if(needprint == 1 && t[next].status == false) needprint = 2;
			next ++;
		}
		if(needprint < 2){
			on = next;
			continue;
		}
		else{
			int AllMoney = 0;
			printf("%s %02d\n" , t[on].name , t[on].month);
			while(on < next){
				while(on < next - 1 && !(t[on].status == true && t[on + 1].status == false)){
					on ++;
				}
				off = on + 1;
				if(off == next){
					on = off ;
					break;
				}
				printf("%02d:%02d:%02d " , t[on].dd , t[on].hh , t[on].mm);
				printf("%02d:%02d:%02d " , t[off].dd , t[off].hh , t[off].mm);
				int time = 0 , money = 0;
				get_ans(on , off , time , money);
				printf("%d $%.2f\n" , time , money / 100.0);
				AllMoney += money;
				on = off;
			}
			printf("Total amount: $%.2f\n" , AllMoney / 100.0);
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值