Black And White HDU - 5113 深搜dfs+剪枝

原题

Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly ci cells.

Matt hopes you can tell him a possible coloring.

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers ci (ci > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c1 + c2 + · · · + cK = N × M .

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1).

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.

Sample Input
4
1 5 2
4 1
3 3 4
1 2 2 4
2 3 3
2 2 2
3 2 3
2 2 2

Sample Output
Case #1:
NO
Case #2:
YES
4 3 4
2 1 2
4 3 4
Case #3:
YES
1 2 3
2 3 1
Case #4:
YES
1 2
2 3
3 1

题解

题目大意
给定一个nm的矩阵,和k种颜色,每种颜色只能分别使用 ci 次,并且保证所有颜色的使用次数加起来等于 nm。要判断是否完成四色问题,并且如果可以填完表格,输出填色的答案。

递归边界:格子填满 或 之前已被标记填满 或 满足剪枝要求
剪枝:某一颜色剩余次数大于当前剩余格子+1的一半

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int map[5][5],color[26],row,column,cn,cases,flag; //map存填色结果,color存颜色使用后剩余的次数,row为行数,column为列数,cn为颜色数,cases为事件数,flag标记是否填完表格

bool check(int rr,int cc,int colour){ //用来判断当前格子的左边和上面填的颜色是否与当前颜色相同(因为是按照从左到右从上到下的顺序填色)
    if(rr-1>=0&&map[rr-1][cc]==colour) //判断rr-1是否超过边缘,如果未达到边缘并且与预填颜色相同,返回false
        return false;
    if(cc-1>=0&&map[rr][cc-1]==colour) //同理判断cc-1是否超过边缘,并判重
        return false;
    return true; //否则可以填色
}

void paint(int r,int c,int step){ //step用来数填了多少个格子,实际上递归边缘 r==row 也可以判断是否填满(下标从0开始)
    for (int i = 1; i <= cn; i++) //剪枝
        if (color[i] > ((step + 1) / 2)) //某一颜色剩余次数大于当前剩余格子的一半
            return;
    if(r==row||flag){ //如果表格填满 或者 之前已经被标记填满
        flag=1;
        return;
    }
    if(!map[r][c]){
        for(int h=1;h<=cn;h++){ //遍历颜色
            if(check(r,c,h)&&color[h]){ //如果颜色满足要求并且当前颜色还存在次数
                map[r][c]=h; //map存入结果
                color[h]--; //次数减少
                if(c==column-1)
                    paint(r+1,0,step-1); //如果达到最大列,那就转到下一行
                else
                    paint(r,c+1,step-1); //否则继续遍历当前行的列
                if(flag) //需要再判断一下,防止填色结果被下面的指令清零
                    return;
                color[h]++; //次数恢复
                map[r][c]=0; //填色归0
            }
        }
    }
}

int main(){
    cin>>cases;
    for(int i=1;i<=cases;i++){
        flag=0;
        //初始化
        memset(map,0,sizeof(map));
        memset(color,0,sizeof(color));
        //输入
        scanf("%d%d%d",&row,&column,&cn);
        int c;
        for(int j=1;j<=cn;j++){
            scanf("%d",&c);
            color[j]=c;
        }
        // dfs遍历
        paint(0,0,row*column);
        
        //输出
        printf("Case #%d:\n",i);
        if(flag){
            puts("YES");
            for(int j=0;j<row;j++) {
                for (int k = 0; k < column - 1; k++)
                    printf("%d ", map[j][k]);
                printf("%d\n", map[j][column - 1]);
            }
        }
        else
            puts("NO");
    }
}
  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值