Tian Ji -- The Horse Racing HDU - 1052 贪心算法 vector

原题

Problem Description
Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.
In this problem, you are asked to write a program to solve this special case of matching problem.

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0
Sample Output
200
0
0

代码
大致题意是每组比赛n次,田忌和齐王各有n匹马,比赛n回合,田忌赢了一回合可以获得200,输了要给齐王200,求出田忌最大能获得多少钱。
主要是要把情况考虑完全

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
int main(){
    int n;
    while(~scanf("%d",&n),n){
        vector<int> q1,q2;
        int t,w1=0,w2=0;

        //输入,q1存田忌马,q2存齐王马
        for(int i=0;i<n;i++){
            scanf("%d",&t);
            q1.push_back(t);
        }
        for(int i=0;i<n;i++){
            scanf("%d",&t);
            q2.push_back(t);
        }

        //对马速从大到小排序
        sort(q1.begin(),q1.end(),greater<int>());
        sort(q2.begin(),q2.end(),greater<int>());

        int sum=0;
        while(!q1.empty()){
            if(q1[0]>q2[0]){ //如果最快马比齐王最快马快,那么最快比最快赢一局
                sum+=200;
                q1.erase(q1.begin());
                q2.erase(q2.begin());
            }
            else if(q1[0]<q2[0]){ //如果最快马比齐王最快马慢,那么用最慢马跟齐王最快马比较输一局
                sum-=200;
                q1.erase(q1.end()-1);
                q2.erase(q2.begin());
            }
            else if(q1[0]==q2[0]){ //如果最快马和齐王最快马一样快,比较两者最慢马
                if(*(q1.end()-1)>*(q2.end()-1)){ //如果最慢马比齐王最慢马快,那么最慢比最慢赢一局
                    sum+=200;
                    q1.erase(q1.end()-1);
                    q2.erase(q2.end()-1);
                }
                else if(*(q1.end()-1)<=*(q2.end()-1)){ //如果最慢马速度小于或等于齐王最慢马速度
                    if(*(q1.end()-1)<q2[0]){ //如果最慢马比齐王最快马慢,那么用最慢抵最快输一局
                        sum-=200;
                        q1.erase(q1.end()-1);
                        q2.erase(q2.begin());
                    }
                    else if(*(q1.end()-1)==q2[0]){ //如果最慢马跟齐王最快马速度相等,平局
                        q1.erase(q1.end()-1);
                        q2.erase(q2.begin());
                    }
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值