D - Super Jumping! Jumping! Jumping!(最长非连续子序列之和)

题目
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
在这里插入图片描述
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

输入
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

输出
For each case, print the maximum according to rules, and one line one case.

样例输入

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

样例输出

4
10
3

题意
输入首先给出数字n(n<=1000),接下来会给出有n个数字的序列。
求其递增序列(可以不连续)的最大和。
输入n为0时结束输入。

举例:
样例1中递增序列有:1,13,12,3,2
其中最大和为 1+3=4,所以输出4

思路
动态规划题,求最长上升序列和的最大值。
我们需要找到状态转移方程。

我们首先要设计一个dp数组,数组中表示当前该数字所能处于的最长上升子序列(以当前数字为最大值)的最大和。

int a[maxn];  //存储序列
int dp[maxn]; //dp[i]:a[i]所处的上升序列的最大和(a[i]处的最优解)
for(int i=1; i<=n; i++)
      cin>>a[i],dp[i]=a[i];   //一开始a[i]对应的dp[i]值为a[i]本身

看一下关键部分:

for(int i=1; i<=n; i++)   //以a[i]为结尾的子序列
{
    for(int j=1; j<i; j++)//遍历a[i]之前的元素
    {
        if(a[j]<a[i])     
            dp[i]=max(dp[i],dp[j]+a[i]);  //状态转移方程
    }
}

最后完善代码就可以了。
「伊丽莎白」!
在这里插入图片描述
代码

#include<bits/stdc++.h>
using namespace std;
const int maxn=1005;
int a[maxn];  //存储序列
int dp[maxn]; //dp[i]:a[i]所处的上升序列的最大和(a[i]处的最优解)
int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n&&n)
    {
        int ma=-1;
        for(int i=1; i<=n; i++)
            cin>>a[i],dp[i]=a[i];   //一开始a[i]对应的dp[i]值为a[i]本身
        for(int i=1; i<=n; i++)   //以a[i]为结尾的子序列
        {
            for(int j=1; j<i; j++)//遍历a[i]之前的元素
            {
                if(a[j]<a[i])
                    dp[i]=max(dp[i],dp[j]+a[i]);  //状态转移方程
            }
        }
        for(int i=1; i<=n; i++)
            ma=max(ma,dp[i]);   //取最大值
        cout<<ma<<endl;
    }
}

最近动态规划学的也是很揪心,自己的脑子跟不上这么抽象的算法。
还得把过程全部打印出来才能有所理解。
在这里插入图片描述
学海无涯,()()()()。

人生啊人生!
在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值