FatMouse's Speed

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
InputInput contains data for a bunch of mice, one mouse per line, terminated by end of file.
The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
Two mice may have the same weight, the same speed, or even the same weight and speed.
OutputYour program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that
W[m[1]] < W[m[2]] < … < W[m[n]]
and
S[m[1]] > S[m[2]] > … > S[m[n]]
In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900Sample Output4
4
5
9
7

主要难度在于表示最大的条件序列的序号,将DP数组设为结构体,一个变量记录值max,另一个变量记录这个max由前面哪个而来;因为题目要求输出任一组即可,所以该代码与样例输出不同

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
struct node{
    int w,s,num;
}a[1010];
bool cmp(node a,node b)
{
    return a.w!=b.w?a.w<b.w:a.s>b.s;
}
struct node2{
    int maxx,fro;
}dp[1010];
int main()
{
    int len=1;
    while(scanf("%d%d",&a[len].w,&a[len].s)!=EOF)
    {
        a[len].num=len;
        dp[len].maxx=1;
        dp[len].fro=0;
        len++;
    }
    len--;
    sort(a+1,a+len+1,cmp);
    int ans=0,pos=0;
    for(int i=1;i<=len;i++)
        for(int j=i-1;j>0;j--)
        {
            if(a[i].w>a[j].w&&a[i].s<a[j].s&&dp[j].maxx+1>dp[i].maxx)
            {
                dp[i].maxx=dp[j].maxx+1;
                dp[i].fro=j;//fro表示前一个的位置(重新排列后的位置)
            }
            if(dp[i].maxx>ans)
            {
                ans=dp[i].maxx;
                pos=i;
            }
        }//pos记录重新排列后的axx最后一个位置
    cout<<ans<<endl;
    int x[1010],t=ans;
    while(pos)//输出的编号是倒着的,要反过来
    {
        x[t]=a[pos].num;
        pos=dp[pos].fro;
        t--;
    }
    for(int i=1;i<=ans;i++)
        cout<<x[i]<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值