A POJ-1456 Supermarket(并查集+贪心)两种代码实现

Supermarket
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25038 Accepted: 11006
Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
在这里插入图片描述

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10
Sample Output

80
185
Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题意:有·N个商品,价格为p,保质期为d。只能在保质期之前(包含d)卖出,并且每天只能卖出一个商品。求最大的利润。

题解:先安排价格高的商品,最好是放在保质期d那一天,如果已经被占(商品价格肯定比它高),往前找。类似并查集找祖宗的过程。注:f[i]只能初始化为-1;如果初始化为0,当保质期为一天有多个商品时,会出现重复计算。

并查集+贪心思想:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n;
int f[10200];
struct note
{
    int p,d;
} q[10100];
 
int cmp(note a,note b)
{
    return a.p>b.p;
}
int getf(int v)
{
    if(f[v]==-1)return v;  //如果当天没被占,就放在当天卖
    else
    {
        f[v]=getf(f[v]);  //如果当天被占,就往前找(祖宗)。
        return f[v];
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(f,-1,sizeof(f)); //f[i]不能·等于·i;天数是不连贯的,和商品标号也没有也无关系。
        int maxn=-1;
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&q[i].p,&q[i].d);
        }
        sort(q+1,q+n+1,cmp);
        int sum=0;
        for(int i=1; i<=n; i++)
        {
            int t=getf(q[i].d);//返回第几天卖
            if(t>0)           //天数为<=0?不存在的,如果如此,这件商品,只能丢弃了。
            {
                sum+=q[i].p;
                f[t]=t-1;   //t天被占用后,它的祖宗应该指向前一天。
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

贪心:思路相同

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n;
int vis[10200];
struct note
{
    int p,d;
}q[10100];
int cmp(note a,note b)
{
     return a.p>b.p;
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&q[i].p,&q[i].d);
        }
        sort(q+1,q+n+1,cmp);
        int sum=0;
        for(int i=1;i<=n;i++)
        {
          if(!vis[q[i].d])
          {
              vis[q[i].d]=1;
              sum+=q[i].p;
          }
          else
          {
              for(int j=q[i].d-1;j>=1;j--)
              {
                  if(!vis[j])
                  {
                      vis[j]=1;
                      sum+=q[i].p;
                      break;
                  }
              }
          }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值