PTA1002

PTA1002 A+B for Polynomials

问题描述:

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1 a​N1 N2 a​N​2 … N​K aN​K
where K is the number of nonzero terms in the polynomial, N​i and a​N​i (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K <⋯<N​2<N1≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

题目分析:

一开始读题没有读懂,看了别人的分析才看出来是指数排列。
输入时按照将相同底数的指数相加,遍历统计非0组的个数,再次遍历按格式输出即可,注意特殊的0。
代码如下:

#include<iostream>
using namespace std;
const int N=1e3+1;
double a[N];
int main()
{
	int n,x;
	double y;
	cin>>n;
	for (int i = 0; i < n; i++)
	{
		cin>>x>>y;
		a[x]+=y;
	}
	cin>>n;
	for (int i = 0; i < n; i++)
	{
		cin>>x>>y;
		a[x]+=y;
	}
	int len=0;
	for (int i = 0; i <= 1000; i++)
	{
		if (a[i]!=0.0)
		{
			len++;
		}
	}
	if(len)
	{
		int i;
		cout<<len<<' ';
		for ( i = 1000; i >= 0; i--)
		{
				if (a[i]!=0.0)
			{
				printf("%d %.1f",i,a[i]);
				len--;
				if(len) cout<<' ';
			}
		}
	}
	else
	{
		cout<<"0";
	}
	return 0;
}


总结

这道题主要的难点还是读题,看懂题后很好做,通过率低的原因还是对于英文题面的理解。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值