PTA-vector(1047/1039)

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

思路

vector这两道题很像,这道题思路很简单但是用string会超时,所以需要使用printf输出char类型的字符串变量。

#include<bits/stdc++.h>
using namespace std;
const int maxx=40001;
const int maxs=2501; 
vector<int> lec[maxs];
char aka[maxx][5];
bool cmp(int a,int b){
	return strcmp(aka[a],aka[b])<0;
}
int main(){
	int n,m;
	cin>>n>>m;
	for(int i=0;i<n;i++){
		int num;
		scanf("%s %d",&aka[i],&num);
		for(int j=0;j<num;j++){
			int a;
			cin>>a;
			lec[a].push_back(i);
		}
	}
	for(int i=1;i<=m;i++){
		cout<<i<<' '<<lec[i].size()<<endl;
		sort(lec[i].begin(),lec[i].end(),cmp);
		for(int j=0;j<lec[i].size();j++){
			printf("%s\n",aka[lec[i][j]]);
		}
	}
	return 0;
}

1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N i (≤200) are given in a line. Then in the next line, N student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

思路

直接暴力求解最后一个点会超时,需要使用字符串哈希的方法求解。

#include<bits/stdc++.h>
using namespace std;
const int maxx=26*26*26*10+1;
vector<int> stu[maxx];
int getHash(string str){
	int sum=0;
	for(int i=0;i<str.size();i++){
		if(str[i]>='0'&&str[i]<='9')
			sum=sum*10+str[i]-'0';
		else if(str[i]>='A'&&str[i]<='Z')
			sum=sum*26+str[i]-'A';
	}
	return sum;
}
int main()
{
	int n,m;
	cin>>n>>m;
	for(int i=0;i<m;i++){
		int x,y;
		cin>>x>>y;
		for(int j=0;j<y;j++){
			string name;
			cin>>name;
			int num=getHash(name);
			stu[num].push_back(x);
		}
	}
	vector<string> names;
	for(int i=0;i<n;i++){
		string name;
		cin>>name;
		cout<<name<<' ';
		int num=getHash(name);
		cout<<stu[num].size();
		sort(stu[num].begin(),stu[num].end());
		for(int j=0;j<stu[num].size();j++){
			cout<<' ';
			cout<<stu[num][j];
		}
		cout<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值