PTA-DFS(1103)

1103 Integer Factorization (30 分)

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + … n[K]^P
where n[i] (i = 1, …, K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12 2+4 2+2 2+2 2+1 2, or 11 2+6 2+2 2+2 2+2 2, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence { a1,a 2,⋯,a K } is said to be larger than { b 1,b 2,⋯,b K } if there exists 1≤L≤K such that a i=b i for ib L .
If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

思路

参考了晴神的代码,思路清晰看了一遍就可以a题了基本。
首先是打表,把待处理数的因子都打在表上,然后就是递归dfs,利用打好的表,进行累加判断,注意边界条件。
如果有相同解,就判断总和是否更大,更大应该更新,从大到小进行dfs的好处是字典序一定是从大到小的,这样就能找出字典序又大,同时总和最大的情况。

#include<bits/stdc++.h>
using namespace std;
int n,k,p;
vector<int> fac,ans,temp;
int now=-1;
int cnt(int x){
	int sum=1;
	for(int i=0;i<p;i++){
		sum*=x;
	}
	return sum;
}
void init(){
	for(int i=0;cnt(i)<=n;i++){
		fac.push_back(cnt(i));
	}
}
void dfs(int index,int Sum,int num,int tempTot){
	if(Sum==n&&num==k){
		if(tempTot>now){
			now=tempTot;
			ans=temp;
		}
		return ;
	}
	if(Sum>n||num>k) return ;	
	if(index>0){
		temp.push_back(index);
		dfs(index,Sum+fac[index],num+1,tempTot+index);
		temp.pop_back();
		dfs(index-1,Sum,num,tempTot);
	}
}
int main()
{
	cin>>n>>k>>p;
	init();
	dfs(fac.size()-1,0,0,0);
	if(ans.empty()){
		cout<<"Impossible"; 
	}
	else{
		cout<<n<<" = ";
		for(int i=0;i<ans.size();i++){
			cout<<ans[i]<<'^'<<p;
			if(i!=ans.size()-1) cout<<" + ";
		} 
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值