Molar mass UVA - 1586

​   An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.

​   When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3H4O3, identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.

​   In this problem, we assume that the molecular formula is represented by only four elements, ‘C’ (Carbon), ‘H’ (Hydrogen), ‘O’ (Oxygen), and ‘N’ (Nitrogen) without parentheses.

​   The following table shows that the standard atomic weights for ‘C’, ‘H’, ‘O’, and ‘N’.

Atomic NameCarbonHydrogenOxygenNitrogen
Standard Atomic Weight12.01 g/mol1.008 g/mol16.00 g/mol14.01 g/mol

​   For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).

​   Given a molecular formula, write a program to compute the molar mass of the formula.

Input

​   Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which is represented after the chemical symbol would be omitted when the number is 1 (2 ≤ n ≤ 99).

Output

​   Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

Sample Input

4
C
C6H5OH
NH2CH2COOH
C12H22O11

Sample Output

12.010
94.108
75.070
342.296

HINT

​   题目大体意思是让你求一个有机分子的摩尔质量,问题的关键是如何求得各个有机分子得各个原子得总数。这里由于每一个原子的总数小于100个,因此可以采用直接判断的方法来求出总数。当然也可以使用递归函数来求出总数,但那就有点不划算了。

Accepted

#include<stdio.h>
#include<string.h>

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		char molar[81];
		int  num[4] = { 0 };					//num数组是用来保存各个原子的总数,下标为0 1 2 3的元素分别是C H O N的总数
		scanf("%s", molar);
		int len = strlen(molar);
		for (int i = 0;i < len;i++)
		{
			if (molar[i] <= '9' && molar[i] >= '0')continue;
			int k;
			if (molar[i] == 'C')k = 0;
			else if (molar[i] == 'H')k = 1;
			else if (molar[i] == 'O')k = 2;
			else if (molar[i] == 'N')k = 3;

			num[k]++;							//首先加上一是为了防止元素后面就是元素的情况,如果后面是数字就再后面减去一抵消
			if (i + 1 < len && molar[i + 1] <= '9' && molar[i + 1] >= '0')
			{
				if (i + 2 < len && molar[i + 2] <= '9' && molar[i + 2] >= '0')
					num[k] += (molar[i + 1] - '0') * 10 + molar[i + 2] - '0' - 1;
				else num[k] += molar[i + 1] - '0' - 1;
			}
		}
		double weigh = num[0] * 12.01 + num[1] * 1.008 + num[2] * 16.00 + num[3] * 14.01;
		printf("%.3lf\n", weigh);				//求出总质量
	}

}

  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值