Squares UVA - 201

A children’s board game consists of a square array of dots that contains lines connecting some of the pairs of adjacent dots. One part of the game requires that the players count the number of squares of certain sizes that are formed by these lines. For example, in the figure shown below, there are 3 squares — 2 of size 1 and 1 of size 2. (The “size” of a square is the number of lines segments required to form a side.)

在这里插入图片描述

Your problem is to write a program that automates the process of counting all the possible squares.

Input

The input file represents a series of game boards. Each board consists of a description of a square array of n 2 dots (where 2 ≤ n ≤ 9) and some interconnecting horizontal and vertical lines. A record for a single board with n 2 dots and m interconnecting lines is formatted as follows:

   Line 1: n the number of dots in a single row or column of the array .

   Line 2: m the number of interconnecting lines.

Each of the next m lines are of one of two types:

   H i j indicates a horizontal line in row i which connects

       the dot in column j to the one to its right in column j + 1

or

   V i j indicates a vertical line in column i which connects

      the dot in row j to the one below in row j + 1

Information for each line begins in column 1. The end of input is indicated by end-of-file. The first record of the sample input below represents the board of the square above.

Output

For each record, label the corresponding output with ‘Problem #1’, ‘Problem #2’, and so forth. Output for a record consists of the number of squares of each size on the board, from the smallest to the largest. lf no squares of any size exist, your program should print an appropriate message indicating so. Separate output for successive input records by a line of asterisks between two blank lines, like in the sample below.

Sample Input

4
16
H 1 1
H 1 3
H 2 1
H 2 2
H 2 3
H 3 2
H 4 2
H 4 3
V 1 1
V 2 1
V 2 2
V 2 3
V 3 2
V 4 1
V 4 2
V 4 3
2
3
H 1 1
H 2 1
V 2 1

Sample Output

Problem #1
2 square (s) of size 1
1 square (s) of size 2
**********************************
Problem #2
No completed squares can be found.

HINT

暴力破解的,使用连两个数组分别储存竖边和横边,然后判断每一个可能的正方形。使用了4个for循环来来判断,最外层循环是正方形的大小,最大到n-1。紧接着两个循环对每一个可能的顶点来判断。最里面的才是判断标准,

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int result(int arrh[][10], int arrv[][10], int n);

int main()
{
	int n, m ,p, q;
	int problem = 1;
	while (scanf("%d %d", &n, &m) != EOF)
	{
		getchar();
		int arrh[10][10] = { 0 };
		int arrv[10][10] = { 0 };	
		char ch;
		for (int i = 0;i < m;i++)
		{
			scanf("%c %d %d", &ch, &p, &q);getchar();
			if (ch == 'H')arrh[p][q]=1;
			else arrv[q][p] = 1;
		}
		if (problem != 1)printf("\n**********************************\n\n");
		printf("Problem #%d\n\n", problem++);
		if (result(arrh, arrv, n)==0)printf("No completed squares can be found.\n");
	}
}

int result(int arrh[][10], int arrv[][10], int n)
{
	int flag = 0;
	for (int i = 1;i < n;i++)
	{
		int sum = 0;
		for (int j = 1;j <= n - i;j++)
		{
			for (int k = 1;k <= n - i;k++)
			{
				int flag1 = 0;
				for (int s = 0;s<i;s++)
				{
					if (!arrh[j][k + s] || !arrh[j + i][k + s] || !arrv[j + s][k] || !arrv[j + s][k + i])
					{
						flag1 = 1;break;
					}
				}
				if (!flag1) { sum++;flag = 1; }
			}
		}
		if (sum)printf("%d square (s) of size %d\n", sum, i);
	}
	return flag;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值