To the Max 最大矩形和

To the Max

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1

8 0 -2

Sample Output
15

题目大意:给定n,代表又n*n的矩阵,求和最大的小矩阵。

定义二维数组存储输入的数据,可以让每(i,j)位置的值为第 j 列 0 ~ i 行的所有值的和。如要得到纵向第 j 列 i~k 行小矩形的和:map[k][j] - map[i][j] ,(令第 j 列第 k 行存储的值减去第 j 列第 i 行存储的值,注意相减的顺序)。然后遍历每一列,将得到的小矩形的和加上其他列的小矩形和,即不断横向扩大小矩形的宽,每次进行比较,得到最大和。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define max(a,b) (a)>(b)?(a):(b)

int main()
{
    int n,map[110][110],sum;
    scanf("%d",&n);
    for(int i = 0; i<n ; i++)
    {
        for(int j = 0; j<n; j++)
        {
            scanf("%d",&map[i][j]);
            if(i)//如果i 不是第0行
                map[i][j] += map[i-1][j];//map[i][j] 存储的是第 j 列 0到 i行的和
        }
    }
    int maxx = -9999;
    for(int i = 0; i<n; i++)//依次遍历行(即矩形的上边)
    {
        for(int j = i+1; j<n; j++)//依次遍历不同的行(即矩形的下边)
        {
            sum = 0;//sum 每次获取不同的行之间的最大矩形和时赋为0
            for(int k = 0; k<n; k++)//依次遍历每一列(即依次扩大矩形的宽度)
            {
                if(sum>=0)
                {
                    sum+=map[j][k] - map[i][k];//sum依次加上每一列的 第i行与第j行之间值的和(注意i与j的位置)
                }
                else//如果sum为负数,就不再需要它原来的值了,因为负数和新的数相加只会越来越小
                    sum=map[j][k] - map[i][k];//注意相减时i与j的位置
                maxx = max(maxx,sum);
            }
        }
    }
    printf("%d\n",maxx);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值