Integer Inquiry(大数相加)

Integer Inquiry

Total Submission(s) : 8 Accepted Submission(s) : 3
Problem Description
One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
"This supercomputer is great,’’ remarked Chip. "I only wish Timothy were here to see these results.’’ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670

题目大意:输入大数,以0结束输入,输出所有数相加的结果。

用字符串接收输入的数,然后倒序存放到整型数组中。每输入一个大数,进行一次相加,由于是倒序相加,在数组中的 0 位置得到的是最大位,所以输出时也要倒序输出,但是创建数组后,把所有位置都初始化为0了,倒序输出得先确定非0位置,在输出,否则结果会有前导0,具体参见代码。

#include<stdio.h>
#include<string.h>
#define N 110

int main()
{
    char str[N];
    int a1[N],a2[N];
    int t,k;
    memset(a2,0,sizeof(a2));
    while(1)
    {
        scanf("%s",str);
        if(strcmp(str,"0") == 0)
            break;
        memset(a1,0,sizeof(a1));//每次输入都要重新初始化为0,不然上一次输入的数据仍保留在数组里
        for(int i = 0,j = strlen(str)-1; str[i] != '\0'; i++)//倒序转成整型数字,因为相加是从个位开始相加,倒序后方便进位。
        {
            a1[j--] = str[i] - '0';
        }
        t = 0;
        //n = max(n,strlen(str));
        for(int i = 0; i<N; i++)
        {
            a2[i]+=a1[i]+t;
            t = a2[i]/10;
            a2[i] %= 10;
        }
    }
    int i;
    for(i = N-1; i>=0; i--)//去前导零
    {
        if(a2[i]!=0)
        {
            break;
        }
    }
    for(int j = i; j>=0; j--)
        printf("%d",a2[j]);
    printf("\n");
    return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值