A1163 Dijkstra Sequence(30分)PAT 甲级(Advanced Level) Practice(C++)满分题解【Dijkstra】

Dijkstra's algorithm is one of the very famous greedy algorithms.
It is used for solving the single source shortest path problem which gives the shortest paths from one particular source vertex to all the other vertices of the given graph. It was conceived by computer scientist Edsger W. Dijkstra in 1956 and published three years later.

In this algorithm, a set contains vertices included in shortest path tree is maintained. During each step, we find one vertex which is not yet included and has a minimum distance from the source, and collect it into the set. Hence step by step an ordered sequence of vertices, let's call it Dijkstra sequence, is generated by Dijkstra's algorithm.

On the other hand, for a given graph, there could be more than one Dijkstra sequence. For example, both { 5, 1, 3, 4, 2 } and { 5, 3, 1, 2, 4 } are Dijkstra sequences for the graph, where 5 is the source. Your job is to check whether a given sequence is Dijkstra sequence or not.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers Nv​ (≤103) and Ne​ (≤105), which are the total numbers of vertices and edges, respectively. Hence the vertices are numbered from 1 to Nv​.

Then Ne​ lines follow, each describes an edge by giving the indices of the vertices at the two ends, followed by a positive integer weight (≤100) of the edge. It is guaranteed that the given graph is connected.

Finally the number of queries, K, is given as a positive integer no larger than 100, followed by K lines of sequences, each contains a permutationof the Nv​ vertices. It is assumed that the first vertex is the source for each sequence.

All the inputs in a line are separated by a space.

Output Specification:

For each of the K sequences, print in a line Yes if it is a Dijkstra sequence, or No if not.

Sample Input:

5 7
1 2 2
1 5 1
2 3 1
2 4 1
2 5 2
3 5 1
3 4 1
4
5 1 3 4 2
5 3 1 2 4
2 3 4 5 1
3 2 1 5 4

Sample Output:

Yes
Yes
Yes
No

代码如下:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int MAXN=1010;
const int INF=0x3fffffff;
int map[MAXN][MAXN],d[MAXN];
bool visit[MAXN];
int nv,ne,k;
int main()
{
    cin>>nv>>ne;
    fill(map[0],map[0]+MAXN*MAXN,INF);
    for(int i=1;i<=ne;i++)
    {
        int v1,v2,w;
        cin>>v1>>v2>>w;
        map[v1][v2]=map[v2][v1]=w;
    }
    cin>>k;
    for(int i=0;i<k;i++)
    {
        vector<int> v(nv);
        for(int j=0;j<nv;j++)
            cin>>v[j];
        bool flag=true;
        fill(visit,visit+MAXN,false);
        fill(d,d+MAXN,INF);//d存的是每个点到起始点的距离
        d[v[0]]=0;//自己到自己为0
        for(int j=0;j<nv;j++)
        {
            int u=v[j];//当前选取的点为题目中查询的序列
            for(int p=1;p<=nv;p++)
            {
                //如果从其他点中找到了比题目给的距离更近的点,则不是迪杰斯特拉序列
                if(visit[p]==false&&d[p]<d[u]){
                    flag=false;
                    break;
                }
            }
            if(flag==false)break;    
            visit[u]=true;
            //计算每个点到始点的距离
            for(int p=1;p<=nv;p++){
                if(visit[p]==false&&map[u][p]!=INF&&d[u]+map[u][p]<d[p])
                    d[p]=d[u]+map[u][p];//某个点通过当前点到达始点比自己直接到达要近(由于前面的点已经确定了,所以要结合前面已经确定的点来考虑)
            }
        }
        if(flag)cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}

运行结果如下:

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值