Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID's of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.
Input Specification:
Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤105). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X
. It is guaranteed that all the ID's are distinct.
The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (≤105). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID's are distinct.
Output Specification:
First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus -- notice that the 7th - 14th digits of the ID gives one's birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.
Sample Input:
5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042
Sample Output:
3
150702193604190912
代码如下:
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
bool cmp(string a,string b)
{
string a1=a.substr(6,8);
string b1=b.substr(6,8);
return a1<b1;
}
int main()
{
int n,m;
cin>>n;
map<string,int> alumnus;
map<string,int> guest;
vector<string> v;
for(int i=1;i<=n;i++){
string id;
cin>>id;
alumnus[id]=1;
}
cin>>m;
for(int i=1;i<=m;i++){
string id;
cin>>id;
v.push_back(id);
guest[id]=1;//来了典礼的
}
sort(v.begin(),v.end(),cmp);
int cnt=0,flag=0,oldest;
for(int i=0;i<v.size();i++)
{
if(alumnus[v[i]]==1){
if(flag==0){
cnt++;
flag=1;
oldest=i;
}
else cnt++;
}
}
cout<<cnt<<endl;
if(cnt==0)cout<<v[0]<<endl;
else cout<<v[oldest]<<endl;
return 0;
}
运行结果如下: