A1140 Look-and-say Sequence(20分)PAT 甲级(Advanced Level) Practice(C++)满分题解【字符串处理】

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

题意分析:

先找规律,新的字串计算前一个字串中出现的数字个数,注意不是按所有数字数来算,相同的数字不连续断开后要重新计算,一开始一直算的整个字符串中的数字数,手算结果一直不对,要注意

代码如下:

我的AC代码: 

#include<bits/stdc++.h>
using namespace std;
//D, D1, D111, D113, D11231, D112213111, ...
int main()
{
	string s;
	int n;
	cin >> s >> n;
	if (n == 1) {
		cout << s << endl;
		return 0;
	}
	s += "1";
	for (int i = 2; i < n; i++) {
		string t = s;
		s = t[0];
		bool continuous = false;
		int cnt=1;
		for (int j = 1; j < t.length(); j++) {
			if (t[j] == t[j - 1]) {
				continuous = true;
				cnt++;
			}
			else continuous = false;
			if (!continuous) {
				s += to_string(cnt);
				s += t[j];
				cnt = 1;
			}
		}
		s += to_string(cnt);
	}
	cout << s << endl;
	return 0;
}

 *柳神的更简洁,但要仔细看:

#include <iostream>
using namespace std;
int main() {
    string s;
    int n, j;
    cin >> s >> n;
    for (int cnt = 1; cnt < n; cnt++) {
        string t;
        for (int i = 0; i < s.length(); i = j) {
            for (j = i; j < s.length() && s[j] == s[i]; j++);
            t += s[i] + to_string(j - i);
        }
        s = t;
    }
    cout << s;
    return 0;
}

运行结果如下:

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值