1001 A+B Format (20分)——C语言实现

1001 A+B Format (20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10^ 6 ≤a,b≤ 10^6. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目大意及思路:

给定a 与 b,计算a + b 的和,并按规定输出,及没3位输出一个逗号。
使用 ( j % 3 == 0 && j != 0) 来判断是否输出逗号。

代码:

#include<stdio.h>
#include<math.h>
int main(){
	int a, b, sum;
	int i = 0, j;
	int flag[10];
	scanf("%d %d", &a, &b);
	sum = a + b;
	if(sum < 0)
		printf("-");
	int num = fabs((float)sum);
	if(num == 0)
		printf("0");
	else{
		while(num > 0){
			flag[i++] = num % 10;
			num /= 10;
		}
		for(j = i-1; j >=0; j--){
			printf("%d", flag[j]);
			if(j % 3 == 0 && j != 0) 
				printf(",");
		}
	}
	return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值