PAT甲级之路--1001 A+B Format(C语言)

题目描述

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目理解,求a+b的和,结果每三位用‘,’隔开。

求解思路:

方法一

C语言:初步尝试,求解两整数之和,若结果<0输出负号,循环结果倒序后每三位输出‘,’ 

#include<stdio.h>

int main(){

int a,b;

int i=0,j=0;

int m,n;

int s[12];

scanf("%d %d",&a,&b);m=a+b;

if(m<0) m=-1*m;

while(m>0){

n=m%10;

// printf("%d**",n);

 

s[i]=n;

m/=10;

 

//printf("%d,%d\n",i,s[i]);

i++;

}

//printf("%d\n",a+b);

if(a+b<0){

printf("-");

}

for(j=i-1;j>=0;j--){

printf("%d",s[j]);

if((j+3)%3==0&&j!=0)

printf(",");

}

}

提交后答案部分错误

检查

漏掉答案为0的情况

此方法效率较低

方法二

 

C语言:初步尝试,借鉴其他人的思想,由于a,b大小限制,所以答案可以分为一下几类讨论

  •  三位分级法,而且-2000000<= sum <= 2000000;所以我们可以分类讨论:(设 c 为sum的绝对值,因为结果有负数,所以要用绝对值进行分类讨论
  • C<1000 (直接输出sum)
  • 1000<= C <1000000 (有一个逗号)
  • C>=1000000 (有两个逗号)
  • 最后,每种情况对应一种输出方式;然后输出结果。

#include<stdio.h>
int main(){
int a,b;
int sum,abssum;
scanf("%d %d",&a,&b);
sum=a+b;
abssum=abs(sum);
if(abssum<1000)
{
    printf("%d",sum);
}
else if(abssum>=1000&&abssum<1000000){
    printf("%d,%03d",sum/1000,abssum%1000);

}
else if(abssum>=1000000){
    printf("%d,%03d,%03d",sum/1000000,(abssum/1000)%1000,abssum%1000);

}
}

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值