1148 Werewolf - Simple Version (20 分)——C/C++(枚举)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  1. player #1 said: “Player #2 is a werewolf.”;
  2. player #2 said: “Player#3 is a human.”;
  3. player #3 said: “Player #4 is a werewolf.”;
  4. player #4 said: “Player #5 is a human.”;
  5. player #5 said: “Player #4 is a human.”.

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:
If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

题目大意:

简单版狼人杀,虽然我没有感觉出哪里简单,哈哈哈 ~ _ ~
本题主要意思是在给定的n个玩家中,有两个狼人,需要找出这两个狼人,并输出序号。每个玩家说一条语句,在这n个玩家中有2个人说谎,即一个狼人与一个农民;在上面输入中用正整数表示农民,负整数表示狼人。如果有解,在一行中按递增顺序输出 2 个狼人的编号;如果解不唯一,则输出最小序列解;若无解则输出 No Solution。

分析及思路:

使用v向量保存每个人说的数字(语句);假设i,j为狼人,双重循环,i从1到n,j从i+1到n;定义lie向量保存说谎的人的下标,a向量标记是狼人还是农民,初始化为农民‘1’;k从1到n遍历v,若 v[k] * a[abs(v[k])] < 0 说明第k个人说谎,把k放入lie向量中;遍历结束后判断,若lie.size() == 2(两个人说谎)且a[lie[0]] + a[lie[1]] == 0(一个为狼人,一个为农民)说明符合条件,输出i与j。

AC代码:

#include<iostream>
#include<cmath>
#include<vector>
using namespace std;

int main(){
	int n;
	cin >> n;
	vector<int> v(n+1);//定义一个n+1长度的向量 
	for(int i = 1; i <= n; i++) cin >> v[i];
	for(int i = 1; i <= n; i++){
		for(int j = i + 1; j <= n; j++){
			vector<int> lie, a(n + 1, 1);//a为定义一个n+1长度且值为1的向量 
			a[i] = a[j] = -1;//假设i,j为狼
			for(int k = 1; k <= n; k++){
				if(v[k] * a[abs(v[k])] < 0) lie.push_back(k);
			} 
			if(lie.size() == 2 && a[lie[0]] + a[lie[1]] == 0){
				cout << i << ' ' << j;
				return 0;
			}
		}
	}
	cout << "No Solution";
    return 0;
} 

注:参考柳神思路(https://blog.csdn.net/liuchuo/article/details/82560876)

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值