【甲级】1010 Radix (25 分)——(数制转换与二分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is “yes”, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number “radix” is the radix of N1 if “tag” is 1, or of N2 if “tag” is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print “Impossible”. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

题目大意:

给定两个数n1与n2,当tag为1时表示n1为radix进制,tag为2是表示n2为radix进制;输出另一没给定进制的数在什么进制下两数相等。

分析及思路:

convart函数:将任意进制数转化为10进制,转化过程中可能产生溢出。

find_radix函数:找到令两个数值相等的进制数。在查找的过程中,需要使用二分查找算法,更快捷方便。

AC代码:

#include<iostream>
#include<string>
#include<algorithm>
#include<cmath>

using namespace std;
long long convart(string n, long long radix){//将任意数值转换为10进制数 
	long long sum = 0;
	int cnt = 0, temp;
	for(int i = n.size() - 1; i >= 0; i--){
		temp = isdigit(n[i]) ? n[i] - '0' : n[i] - 'a' + 10;
		sum += temp * pow(radix, cnt++);
	}
	return sum;
}

long long find_radix(string n, long long num){//寻找相等的进制 
	char s = *max_element(n.begin(), n.end());
	long long low = (isdigit(s) ? s - '0' : s - 'a' + 10) + 1;//最小进制为该数中最大的数字 
	long long high = max(num, low);//最大进制为另一个数 
	while(low <= high){
		long long mid = (low + high) / 2;
		long long t = convart(n, mid);
		//如果使用当前进制转化得到数值比另一个大或者小于0,说明这个进制太大 
		if(t < 0 || t > num) high = mid - 1;
		else if(t == num) return mid;
		else low = mid + 1;
	}
	return -1;
}

int main(){
	string n1, n2;
	long long tag = 0, radix = 0, R_radix;
	cin >> n1 >> n2 >> tag >> radix;
	
	//当第一个数的进制为radix时,把该数转换为10进制,同第二个数传递给find_radix函数 
	//把给了进制的数转换为10进制,同另一个数传递 
	if(tag == 1) 
		R_radix = find_radix(n2, convart(n1, radix));
	else 
		R_radix = find_radix(n1, convart(n2, radix));
	
	if(R_radix == -1) cout << "Impossible" << endl;
	else cout << R_radix << endl;
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值