1122 Hamiltonian Cycle (25分)——C语言实现

1122 Hamiltonian Cycle (25分)

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V ​1 ​​ V ​2 ​​ … V ​n ​​

where n is the number of vertices in the list, and Vi 's are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题目大意:

给定一个图,再给定若干条路径,判断路径是否满足哈密顿圈。

思路:

满足下面条件即为哈密顿圈:
(1)回路,即第一个顶点等于最后一个顶点且路径数等于顶点数加一。
(2)除起点外每个顶点只经过一次。
(3)所给路径前后应连通,即G[v[i]][v[i-1]] != 0。

代码:

#include<stdio.h>
#define maxn 210

int G[maxn][maxn]={0};//存储图
int v[maxn]={0};//用于存储输入的k个结点
int vexnum,arcnum;

int Judge(int N, int cnt[]){
	if(N != vexnum + 1 || v[1]!=v[N])
		return 0;
	for(int i=1;i<=vexnum;i++){
		if(cnt[i]!=1)
			return 0;
	}
	for(int i=2;i<=vexnum+1;i++){
		if(!G[v[i]][v[i-1]])
			return 0; 
	}
	return 1;
}

int main(){
	int i,j;
	scanf("%d %d",&vexnum,&arcnum);
	for(i=1;i<=arcnum;i++){
		int v1,v2;
		scanf("%d %d",&v1,&v2);
		G[v1][v2]=G[v2][v1]=1;
	}
	int k;
	scanf("%d",&k);
	for(i=1;i<=k;i++){
		int N;
		int cnt[maxn] = {0};
		scanf("%d",&N);
		for(j=1;j<=N;j++){
			scanf("%d",&v[j]);
			if(j<N)
			    cnt[v[j]]++;
		}
		if(Judge(N,cnt)==1)
			printf("YES\n");
        else
			printf("NO\n");
	}
	return 0;
}
  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值