08-图8 How Long Does It Take(浙大数据结构)

中国大学MOOC-陈越、何钦铭-数据结构-2022夏

2 天

08-图8 How Long Does It Take

分数 25

作者 陈越

单位 浙江大学

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

coding :

#include <iostream>
#include <algorithm>
#include <queue>
#include <stack>

using namespace std;

struct ENode
{
    int v;
    int cost;
};

const int maxn = 110;
vector<ENode> Adj[maxn];
int ve[maxn];
int inDegree[maxn];
stack<int> topOrder;

int Nv,Ne;

void Read(); //读入数据
bool topSort();

int main()
{
    Read();
    if(topSort()==false)
        cout << "Impossible\n";
    else
    {
        //cout << ve[Nv-1] << endl;  //直接输出ve[Nv-1] 有可能不对,当最后完成的任务不是第Nv件事件时;
        cout << *max_element(ve,ve+Nv) << endl;
    }
    return 0;
}

void Read() //读入数据
{
    cin >> Nv >> Ne;
    for(int i=0;i<Ne;++i)
    {
        int u,v,cost;
        cin >> u >> v >> cost;
        Adj[u].push_back({v,cost});
        inDegree[v]++;
    }
}

bool topSort()
{
    //fill(ve,ve+Nv,0);
    queue<int> q;
    for(int i=0;i<Nv;++i)
        if(inDegree[i]==0)
            q.push(i);

    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        topOrder.push(u);

        for(int i=0;i<Adj[u].size();++i)
        {
            int v=Adj[u][i].v;
            inDegree[v]--;
            if(inDegree[v]==0)
                q.push(v);

            if(ve[u]+Adj[u][i].cost > ve[v])
            {
                ve[v]=ve[u]+Adj[u][i].cost;
            }
        }
    }

    if(topOrder.size() == Nv)
        return true;
    else
        return false;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值