PAT A1052 Linked List Sorting

1052 Linked List Sorting

分数 25

作者 CHEN, Yue

单位 浙江大学

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

 

 * 静态数组模拟链表,定义一个结构体存储一个结点,节点信息除了节点地址,数据大小,下一个
 * 结点的地址以外,还要一个flag变量来标识一个链表上的数组下标,只要结点在链表中,则将
 * 此节点的地址下标对应结构体中的flag变量变为1,初始为0,随后再排一个序,按照flag变量
 * 递降排序,那么flag = 0 的节点都会排在后面去,同时记录在链表上的结点数量,为什么还要
 * 统计链表上的结点数量,难道不直接是n吗,因为题目可能会给出无效结点,所以需要统计。
 *
 * 排序先按照flag递降排序,flag值相同的结点按照dat值递增排序,得到题目要求。

/**
 * 静态数组模拟链表,定义一个结构体存储一个结点,节点信息除了节点地址,数据大小,下一个
 * 结点的地址以外,还要一个flag变量来标识一个链表上的数组下标,只要结点在链表中,则将
 * 此节点的地址下标对应结构体中的flag变量变为1,初始为0,随后再排一个序,按照flag变量
 * 递降排序,那么flag = 0 的节点都会排在后面去,同时记录在链表上的结点数量,为什么还要
 * 统计链表上的结点数量,难道不直接是n吗,因为题目可能会给出无效结点,所以需要统计。
 * 
 * 排序先按照flag递降排序,flag值相同的结点按照dat值递增排序,得到题目要求。
*/


#include <iostream>
#include <algorithm>

using namespace std;

struct Node
{
    int add, dat, nex, flag;
    
    bool operator < (const Node &a) const
    {
        if(flag != a.flag)
            return flag > a.flag;
        else 
            return dat < a.dat;
    }
};

const int N = 1e5+10;
struct Node a[N];

int main()
{
    int n, h;
    cin >> n >> h;
    for(int i=0; i<n; ++i)
    {
        int add, d, nex;
        cin >> add >> d >> nex;
        a[add] = {add, d, nex, 0};
    }
    
    int temp = h, cnt = 0;
    while(temp != -1)
    {
        ++cnt;
        a[temp].flag = 1;
        temp = a[temp].nex;
    }
    
    sort(a, a+N);
    
    if(cnt)
        printf("%d %05d\n", cnt, a[0].add);
    else 
        printf("%d -1\n", cnt);
    
    for(int i=0; i<cnt; ++i)
    {
        if(i < cnt-1) //打印前cnt-1个节点
            printf("%05d %d %05d\n", a[i].add, a[i].dat, a[i+1].add);
        else //输出最后一个节点
            printf("%05d %d -1\n", a[i].add, a[i].dat);
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值