Power Strings(求最小循环节)

题目链接poj2406

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

求最小循环节可此参考文章
如果len可以被len - next[len]整除,则表明字符串S可以完全由循环节循环组成,循环周期T=len/L。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#define N 2000000
using namespace std;
char str[N];
int nextt[N];
void getnext(char *s,int slen)
{
	nextt[0]=0;nextt[1]=0;
	for(int i=1;i<slen;i++)
	{
		int j=nextt[i];
		while(j&&s[i]!=s[j]) j=nextt[j];
		nextt[i+1] = (s[i]==s[j])?j+1:0;
	}
}

int main()
{
	while(1)
	{
		memset(nextt,0,sizeof(nextt));
		scanf("%s",&str);
		if(str[0]=='.') break;
		int slen =  strlen(str);
		getnext(str,slen);
		
		int k = slen - nextt[slen];
		if(slen%k==0) cout<<slen/k<<endl;
		else cout<<1<<endl;
		
	}
	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值