算法笔记入门——问题 E: Shortest Distance (20)

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7

本题题意:这是一道英文题,他的意思是,第一行输入:第一个数表示有N条路,并在之后给出N个数表示N条道的路径长度,这些路会形成一个环,第二行的输入:需要计算M次给定两个节点之间的最短距离,接下来的M行就是两个节点的序号

在这里插入图片描述
图片取自另外一篇博客。

思路分析:五个出口,依次输入的五个数据,是该出口到下一出口的距离,构成一个圆环,我们既可以选择顺时针走,也可以逆时针走,当然题目中我们是要选择最短的一条距离来走,所以最后比较一下两者大小,取最小值即可得到最小的距离。

首先看下别人的思路代码,我不是采用的这种,但是我个人认为这种方法思路也很清晰,并且个人认为比我的方法更好。
 
#include<iostream>
#include<string>
#include<string.h>
using namespace std;
 
int main() {
int N,M;
scanf("%d",&N);
int dis[N+1]={0};
//用来存储每条边的长度 dis[i]来存储Ni到N(i+1) 
int D[N+1]={0};
//D[i]用来存储从N1到Ni的下一个节点的长度(顺时针),
//这样可以存储到整个环的长度 ,如果只是N1到Ni,那么只能存储到N1到N5的距离
 
int sum=0; 
int min=0;//最后的输出 
for(int i=1;i<=N;i++){   //i从1开始 
	scanf("%d",&dis[i]); 
	sum+=dis[i];
	D[i]=sum;
}	
scanf("%d",&M);
int a,b;
for(int i=0;i<M;i++){
	
	scanf("%d %d",&a,&b);
	 //为了避免相减为负数,还要比较大小,令a>b
	 if(b>a){
	 	int temp=a;
	 	a=b;
	 	b=temp;
	 } 
	 //
	 int c1=D[a-1]-D[b-1];
	 int c2=sum-c1;
	 min=c1>c2?c2:c1;
 
	 printf("%d\n",min);
	
}
 
 
return 0;
 
}
	
### 下面是我的代码	
#include <bits/stdc++.h>
int main()
{
    int n;
    scanf("%d",&n);
    int a_[n+1]={0};
    int q=0;
    for(int i=1;i<n+1;i++){
        scanf("%d",&a_[i]);
        q+=a_[i];//q的值计算顺时针一圈的距离总和
    }
    int x;
    scanf("%d",&x);
    for(int i=0;i<x;i++){
        int a,b;
        scanf("%d%d",&a,&b);
        if(b<a){
            int xt=b;
            b=a;
            a=xt;
        }
        int s=0;
        for(int j=a;j<b;j++){
            s +=a_[j];//计算顺时针方式的距离
        }
        int max=0;
        int x1=q-s;
        if((q-s)<s){
            s=q-s;//比较获取最小距离的值
        }
        printf("%d\n",s);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值