A+B for Polynomials python实现

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

结尾无空行

Sample Output:

3 2 1.5 1 2.9 0 3.2

结尾无空行

这道题用python实现,最开始的思路是开一个数组,多项式表达式按指数顺序将系数存入数组,但是这样会浪费一定空间,下意识想到了用链表解决,在网上看了大佬的解答,发现写代码时脑子真是个好东西,可惜本鶸没有。通过这道题找到了字典的正确打开方式。

A=[eval(i) for i in input().split()[1:]]
B=[eval(i) for i in input().split()[1:]]
 
d={}                                        #把数据存放入字典            
for i in range(0,len(A),2):             
    d[A[i]]=d.get(A[i],0)+A[i+1]
 
for i in range(0,len(B),2):
    d[B[i]]=d.get(B[i],0)+B[i+1]
 
for i in list(d.keys()):               #删除系数为0的项,注意要使用list(d.keys())不然会报错
    if d[i]==0:
        del d[i]
 
d=sorted(d.items(),key=lambda x:x[0],reverse=True)  #按照指数进行排序
 
print(len(d),end="")
for x,y in d:
    print(" {} {:.1f}".format(x,y),end="")

#注意控制输出格式

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值