HDU-1002 A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

这道题的陷阱就是格式输出

#include<stdio.h>
#include<string.h>
long long a[1050],a1[1050],sum[1050];
char s[1050],s1[1050];
long long i,j,l,l1,t,n=1;
int main()
{
	scanf("%d",&t);
    for(n=1;n<=t;n++)
    {
    	scanf("%s %s",s,s1);
        l=strlen(s);l1=strlen(s1);
        for(i=0;i<=1040;i++)
        {
            a[i]=0;a1[i]=0;sum[i]=0;
        }
        for(i=l-1,j=1;i>=0;i--,j++)
        a[j]=s[i]-'0';
        for(i=l1-1,j=1;i>=0;i--,j++)
        a1[j]=s1[i]-'0';
        for(i=0;i<=1010;i++)
        {
            sum[i]+=a1[i]+a[i];
            if(sum[i]>=10)
            {
                sum[i+1]++;
                sum[i]=sum[i]%10;
            }
        }
        for(i=1010;i>=0;i--)
        {
            if(sum[i]!=0)
            break;
        }
        printf("Case %d:\n",n);
        printf("%s + %s = ",s,s1);
        if(i==-1)
		printf("0");
        for(j=i;j>0;j--)
        printf("%lld",sum[j]);
        if(t!=n)
        printf("\n\n");
        else printf("\n");
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wa_Automata

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值