A + B Problem II HDU - 1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 337118    Accepted Submission(s): 65402



Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
题解:简单的大数相加,注意下细节就行了……
#include<bits/stdc++.h>
using namespace std;
char x[1005],y[1005];
int a[1005],b[1005];
void fun(char x[1005])
{
    int a=strlen(x);
    for(int i=0;i<a/2;i++)/*注意不能写成i<=a/2*/
        swap(x[i],x[a-i-1]);
}
int main()
{
    int t,s=1;
    scanf("%d",&t);
    while(t--)
    {
        if(s!=1)
            printf("\n");
        scanf("%s%s",x,y);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        printf("Case %d:\n",s);
        printf("%s + %s = ",x,y);
        fun(x),fun(y);
        for(int i=0;i<strlen(x);i++)
            a[i]=x[i]-'0';
        for(int i=0;i<strlen(y);i++)
            b[i]=y[i]-'0';
        int d=0;
        for(int i=0;i<1005;i++)
        {
            int s=a[i]+b[i]+d;
            a[i]=s%10;
            d=s/10;
        }
        int f=0;
        for(int i=1004;i>=0;i--)
            if(a[i])
        {
            f=i;
            break;
        }
        for(int i=f;i>=0;i--)
            printf("%d",a[i]);
        printf("\n");
        s++;
    }
}
//char x[1005],y[1005];
//void fun(char x[1005])
//{
//    int a=strlen(x);
//    for(int i=0;i<a/2;i++)
//        swap(x[i],x[a-i-1]);
//}
//int main()
//{
//    int t,s=1;
//    scanf("%d",&t);
//    while(t--)
//    {
//        if(s!=1)
//            printf("\n");
//        scanf("%s%s",x,y);
//        printf("Case %d:\n",s);
//        printf("%s + %s = ",x,y);
//        fun(x),fun(y);
//        int a=strlen(x),b=strlen(y);
//        if(a<b)
//        {
//            for(int i=a;i<b;i++)
//                x[i]='0';
//            x[b]='\0';
//        }
//        else
//        {
//            for(int i=b;i<a;i++)
//                y[i]='0';
//            y[a]='\0';
//        }
//        int d=0;
//        for(int i=0;i<max(a,b);i++)
//        {
//            int s=x[i]-'0'+y[i]-'0'+d;
//            x[i]=s%10+'0';
//            d=s/10;
//        }
//        fun(x);
//        printf("%s\n",x);
//        s++;
//    }
//}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值