POJ-1598 Excuses, Excuses!

做本题之前介绍一下map函数

map函数

Problem Description
Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input
Input to your program will consist of multiple sets of data.

Line 1 of each set will contain exactly two integers. The first number (1 <= K <= 20) defines the number of keywords to be used in the search. The second number (1 <= E <= 20) defines the number of excuses in the set to be searched.

Lines 2 through K+1 each contain exactly one keyword.

Lines K+2 through K+1+E each contain exactly one excuse.

All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L (1 <= L <= 20) and will occupy columns 1 through L in the input line.

All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.

Excuses will contain at least 1 non-space character.

Output
For each input set, you are to print the worst excuse(s) from the list.

The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.

If a keyword occurs more than once in an excuse, each occurrence is considered a separate incidence.

A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

After each set of output, you should print a blank line.

Sample Input
5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary… AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890…,0987654321!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework … note outdated keywords?

Sample Output
Excuse Set #1
Can you believe my dog died after eating my canary… AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
map<string, int>x;
int main()
{
	char b[100][1000],a[100][1000],c[100][1000],aa[200];
	int m,n,i,j,sum=1,maxn;
	while(scanf("%d%d\n",&m,&n)!=EOF)
	{
		for(i=0;i<m;i++)
		gets(a[i]);
		for(i=0;i<n;i++)
		{
			gets(c[i]);
			x[c[i]]=0;
		}
		for(i=0;i<n;i++)
		{
			int l=strlen(c[i]),s=0,k;
			for(j=0;j<l;j++)
			{
				if(isalpha(c[i][j]))
	    		aa[s++]=tolower(c[i][j]);
				else 
				{
					s=0;
					for(k=0;k<m;k++)
	    			if(strcmp(aa,a[k])==0)
	    			x[c[i]]++;
	    			memset(aa,'\0',sizeof(aa));
				}
			}
		}
//		for(i=0;i<n;i++)
//		printf("%d ",x[c[i]]);
		maxn=x[c[0]];
		for(i=1;i<n;i++)
		{
			if(maxn<x[c[i]])
			maxn=x[c[i]];
		}
		printf("Excuse Set #%d\n",sum++);
		for(i=0;i<n;i++)
		{
			if(maxn==x[c[i]])
			printf("%s\n",c[i]);
		}
		printf("\n");
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wa_Automata

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值