HDU - 6225 Little Boxes(__int128的使用)

HDU - 6225 Little Boxes(__int128的使用)

Problem Description
Little boxes on the hillside.
Little boxes made of ticky-tacky.
Little boxes.
Little boxes.
Little boxes all the same.
There are a green boxes, and b pink boxes.
And c blue boxes and d yellow boxes.
And they are all made out of ticky-tacky.
And they all look just the same.

Input
The input has several test cases. The first line contains the integer t (1 ≤ t ≤ 10) which is the total number of test cases.
For each test case, a line contains four non-negative integers a, b, c and d where a, b, c, d ≤ 2^62, indicating the numbers of green boxes, pink boxes, blue boxes and yellow boxes.

Output
For each test case, output a line with the total number of boxes.

Sample Input
4
1 2 3 4
0 0 0 0
1 0 0 0
111 222 333 404

Sample Output
10
0
1
1070

#include<cstdio>

inline void read(__int128 &x) 
{
    int f=1;x=0;char s=getchar();
    while(s<'0'||s>'9'){if(s=='-')f=-1;s=getchar();}
    while(s<='9'&&s>='0')x=x*10+(s^48),s=getchar();
    x*=f;
}

inline void print(__int128 x)
{
	if(x<0) putchar('-'),x=-x;
    if(x>9) print(x/10);
    putchar(x%10+'0');
}

int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        __int128 a,b,c,d;
        read(a);read(b);read(c);read(d);
        print(a+b+c+d);
        puts("");
    }
    return 0;
}
import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    static Scanner cin = new Scanner(System.in);
    public static void main(String[] args) {
        int T=cin.nextInt();
        while(T-->0)
        {
            BigInteger a=cin.nextBigInteger();
            BigInteger b=cin.nextBigInteger();
            BigInteger c=cin.nextBigInteger();
            BigInteger d=cin.nextBigInteger();
            System.out.println(a.add(b).add(c).add(d));
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wa_Automata

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值