HDU - 1069 Monkey and Banana(DP+LIS)

Monkey and Banana

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:给定 n 种 长方体的三维长度,每种有无限个,让你堆成塔,相邻两个长方体下面的那个长和宽严格大于上面的长和宽,求最高可堆积的高度;

分析:每种长方体有六种摆放方式,我们把所有长方体的所有摆放方式按长宽从小到大排序,设dp[i] 表示以排序后的第 i 个长方体为底部能堆积的最高高度,则往前找比它长宽严格小的更新就可以了,即:
d p [ i ] = m a x ( ∑ j = 0 i − 1 d p [ j ] + k [ i ] . h ) dp[i]=max(\sum_{j=0}^{i-1}dp[j]+k[i].h) dp[i]=max(j=0i1dp[j]+k[i].h)

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<array>
using namespace std;
int main()
{
	int n,T=1;
	while(cin>>n,n)
	{
		vector<array<int,3> > k;
		for(int i=1;i<=n;i++)
		{
			int a,b,c;cin>>a>>b>>c;
			k.push_back({a,b,c});
			k.push_back({a,c,b});
			k.push_back({b,a,c});
			k.push_back({b,c,a});
			k.push_back({c,a,b});
			k.push_back({c,b,a});
		}
		sort(k.begin(),k.end());
		vector<int> dp(6*n);
		for(int i=0;i<6*n;i++)
		{
			dp[i]=k[i][2];
			for(int j=0;j<i;j++)
				if(k[i][0]>k[j][0] && k[i][1]>k[j][1])
					dp[i]=max(dp[i],dp[j]+k[i][2]);
		}
		int ans=0;
		for(int i=0;i<6*n;i++) ans=max(ans,dp[i]);
		cout<<"Case "<<T++<<": maximum height = "<<ans<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wa_Automata

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值