2021-07-27

Recently, Peter saw the equation x0+2x1+4x2+...+2mxm=nx0+2x1+4x2+...+2mxm=n. He wants to find a solution (x0,x1,x2,...,xm)(x0,x1,x2,...,xm) in such a manner that ∑i=0mxi∑i=0mxi is minimum and every xixi (0≤i≤m0≤i≤m) is non-negative.

Input

There are multiple test cases. The first line of input contains an integer TT (1≤T≤105)(1≤T≤105), indicating the number of test cases. For each test case:

The first contains two integers nn and mm (0≤n,m≤109)(0≤n,m≤109).

Output

For each test case, output the minimum value of ∑i=0mxi∑i=0mxi.

Sample Input

10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3

Sample Output

1
2
2
3
2
2
3
2
3
2

题意:满足上面等式的情况下,x和最小

贪心思想,递归代码

#include"stdio.h"
#include"math.h"
#include"string.h"
#include"algorithm"
#include"iostream"
using namespace std;
typedef long long ll;
ll dfs(ll x,ll y)
{
	if(x<=0)
		return 0;
	while(y>x) y/=2;
	ll k=x/y;
	if(k*y==x)
		return k;
	else
		return k+dfs(x-k*y,y);
}
int main()
{
	ll y,n,m,w;
	cin>>w;
	while(w--)
	{
		cin>>n>>m;
		if(m>=30)//m>30,y值无法正确计算,会出现runtime error
		m=29;
		y=pow(2,m);
		cout<<dfs(n,y)<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值