hdu 5747 Aaronson【贪心】

Aaronson

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 319    Accepted Submission(s): 199


Problem Description
Recently, Peter saw the equation x0+2x1+4x2+...+2mxm=n . He wants to find a solution (x0,x1,x2,...,xm) in such a manner that i=0mxi is minimum and every xi ( 0im ) is non-negative.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105) , indicating the number of test cases. For each test case:

The first contains two integers n and m (0n,m109) .
 

Output
For each test case, output the minimum value of i=0mxi .
 

Sample Input
10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3
 

Sample Output
1
2
2
3
2
2
3
2
3
2

中文题意:



思路:


1、显然,xi的系数就是2^m,而且n最大是10^9,显然,2^31就足够让您贪心了,我们尽量让数字系数大的尽可能使用上,那么我们从m=31开始向前贪心,(从31到0);


2、然后对于每一个系数为2^m的数进行贪心的拿取,尽可能多的拿当前xi,维护值累加即可。


Ac代码:


#include<stdio.h>
#include<string.h>
using namespace std;
#define ll long long int
int ans[51515];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll n,m;
        scanf("%I64d%I64d",&n,&m);
        ll output=0;
        if(n%2==1)
        {
            output=1;
            n-=1;
        }
        if(m>31)m=31;
        for(int i=m;i>=0;i--)
        {
            ll tmp=1<<i;
            ll fuck=n/tmp;
            output+=fuck;
            n-=tmp*fuck;
            if(n==0)break;
        }
        printf("%I64d\n",output);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值