D - 求和

题目
Given a sequence, you’re asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
Input
The first line of the input has an integer T (1≤T≤10), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m (1≤n≤100000, 1≤m≤5000).
2.The second line contains n positive integers x (1≤x≤100) according to the sequence.
Output
Output T lines, each line print a YES or NO.
Sample Input
2
3 3
1 2 3
5 7
6 6 6 6 6
Sample Output
YES
NO

#include<bits/stdc++.h>
using namespace std;
#define maxn 11111
int t,n,m,x,sum,mark,flag[maxn];
int main()
{
	cin>>t; 
	while(t--)
	{
		cin>>n>>m;
		sum=mark=0;
		memset(flag,0,sizeof(flag));
		flag[0]=1;
		for(int i=1;i<=n;i++)
		{
			cin>>x;
			sum=(sum+x)%m;
			if(!flag[sum])flag[sum]=1;
			else mark=1;
		}
		if(mark==1) 
				cout<<"YES"<<endl;
			else
				cout<<"NO"<<endl; 
	}
	return 0;	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值