题目描述
假设利用两个线性表LA和LB分别表示两个集合A和B(即:线性表中的数据元素即为集合中的成员),现要求一个新的集合A=A∪B。这就要求对线性表做如下操作:扩大线性表LA,将存在于线性表LB中而不存在于线性表LA中的数据元素插入到线性表LA中去。只要从线性表LB中依次取得每个元素,并依值在线性表LA中进行查访,若不存在,则插入之。上述操作过程可用下列算法描述之。
图:将两个列表合并的算法(C/C++描述)
上图算法中,在第8行取得集合B中的元素,然后再在第10行插入到集合A中。你的任务是先输出集合A和集合B中的元素,每个集合在一行中输出。然后每次在将集合B中的元素取出插入到集合A尾部后输出集合A中的元素。当然你的代码可以和上面的代码不一样,只要有相同的输出即可。
输入
有多组测试数据,每组测试数据占两行。第一行是集合A,第一个整数m(0<m<=100)代表集合A起始有m个元素,后面有m个整数,代表A中的元素。第二行是集合B,第一个整数n(0<n<=100)代表集合B起始有n个元素,后面有n个整数,代表B中的元素。每行中整数之间用一个空格隔开。
输出
每组测试数据输出n+2行:前两行分别输出集合A、集合B中的数据,后面n行是每次从B中取出元素插入到A尾部后的集合A。每行整数之间用一个空格隔开,每组测试数据之间用一行空行隔开。
样例输入
5 1 5 2 6 3 3 1 7 9 1 3 2 2 7 4 2 5 1 4 4 1 2 4 5
样例输出
1 5 2 6 3 1 7 9 1 5 2 6 3 1 5 2 6 3 7 1 5 2 6 3 7 9 3 2 7 3 2 3 2 7 2 5 1 4 1 2 4 5 2 5 1 4 2 5 1 4 2 5 1 4 2 5 1 4
下面用C++实现
#include<iostream>
using namespace std;
typedef int ElemType;
typedef int value;
#define maxsise 200
typedef struct {
ElemType A[maxsise];
int len;
}List;
int ListLength(List L){
return L.len;
}
bool LocateElem(List L,value e)
{
for(int i=0;i<L.len;i++)
{
if(L.A[i]==e)
return true;
}
return false;
}
void ListInsert(List &L,int len,ElemType e){
//len=L.len;
L.A[len-1]=e;
L.len++;
}
void ListShow(List L){
for(int i=0;i<L.len;i++)
cout<<L.A[i]<<" ";
cout<<endl;
}
ElemType GetElem(List &L,int i,ElemType &e){
e=L.A[i-1];
return e;
}
void Union(List &La,List &Lb){
int La_len,Lb_len,i;
ElemType e;
La_len=ListLength(La);
Lb_len=ListLength(Lb);
for(i=1;i<=Lb_len;i++){
GetElem(Lb,i,e);
if(!LocateElem(La,e))
{
ListInsert(La,++La_len,e);
}
ListShow(La);
}
}
int main(){
List La,Lb;
int m,n;
while(cin>>m){
La.len=m;
for(int i=0;i<m;i++)
cin>>La.A[i];
cin>>n;
Lb.len=n;
for(int i=0;i<n;i++)
cin>>Lb.A[i];
ListShow(La);
ListShow(Lb);
Union(La,Lb);
cout<<endl;
}
return 0;
}